Search Issue Tracker




Found in [Package]


Issue ID




[VSCode] OmniSharp project reference warnings are thrown in VSCode console when using VSCode 1.1.4

Package: VS Code


How to reproduce:
1. Create a new Unity project
2. Make sure that your External Code Editor is set to VSCode and VSCode package version is 1.1.4
3. Click on Assets > Open C# Project
4. Once the VSCode window is open, go to the Output tab and inspect OmniSharp Logs

Expected results: No warnings regarding the referenced project being missed are thrown
Actual results: Many "Expected project reference Unity.TextMeshPro.Editor.csproj to be already loaded for project Assembly-CSharp" warnings are thrown

Reproducible with: 2019.2.19f1, 2019.3.0f6, 2020.1.0a20
Reproducible with package version: 1.1.4
Not reproducible with package version: 1.1.3

1. Downgrading VSCode package to version 1.1.3 fixes the issue.
2. Reproduced on Windows and MacOS.

Comments (26)

  1. Eristen

    Jan 14, 2022 15:17

    Using Unity 2020.35.f1 with Visual Studio Code Editor plugin v1.2.4, problem still persists. I solved it by:
    - downgrading the plugin to 1.1.3,
    - erasing the .sln and .csproj files,
    - regenerating them,
    - opening VSCode,
    - and finally upgrading the plugin to 1.2.4

  2. absurdnoize

    Sep 10, 2021 15:51

    Using VS Code and Unity 2020.1.14.f
    I have the same issue. I am afraid to brake Intellisense, but so far no solution worked.

  3. Jules86

    May 05, 2020 09:47

    The issue is present in 1.1.3 in 2019.3.4 on Windows 10.
    Downgrading to 1.1.2 removes the errors in VS Code, but the intellisense / autocomplete still can't resolve the new references.

  4. neomarian

    May 04, 2020 00:21

    Still not fixed

  5. SongAngel

    Mar 26, 2020 01:46

    For me upgrading the project settings to Api compatibility level .NET 4.x fixed the problem. Downgrading the VS Code extension to 1.1.3 did not fix the issue. Running Arch Linux here.

  6. gokhan_wroomm

    Mar 24, 2020 22:54

    The version I use 2019.3.5f1. I downgrading VS Code Editor 1.1.3 version but not fix my problem. When i entered c# Scripts, i cannot import using UnityEngine.AI so ı cannot use NavMesh.. Please help me for this problem.


  7. unayozan

    Mar 24, 2020 19:47

    Solved this by going into the preferences, external tools, and set the "Generate all .csproj files." to true.
    Using 2019.3.6f1, Windows 10, VS Code package version 1.1.4.

  8. caglarenes

    Mar 24, 2020 01:17

    Reproducible with 2019.3.6f1 and package version 1.2.0 on Windows 10 and OSX 10.15

  9. PhoenSXar

    Mar 23, 2020 03:45

    Reproducible with 2019.3.2f1 and package version 1.1.4 on Windows 10.
    Reproducible with 2019.3.2f1 and package version 1.2.0 on Windows 10.

  10. Kruczek

    Mar 22, 2020 15:04

    Reproduced on 2019.3.6f1, both packages 1.1.4 and 1.1.3 have the same issue.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.