Search Issue Tracker

Active

Votes

187

Found in

2018.3.0b9

Issue ID

1099125

Regression

Yes

[VR] Particle Systems cause "task.rasterData.indexBuffer == NULL" error and lead to graphical glitches

VR

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Secondary functionality broken

Steps to reproduce:
1. Create a new project
2. Enable VR
3. Create a particle system
4. Enter playmode and put it in your HMDs view

richardk Edit:
5. If error doesn't show, repeat Stop / Play of playmode again. (when doing this i can repro it with the MockHMD)

Result: "task.rasterData.indexBuffer == NULL" error in the console and potential graphical glitches

Reproduced on 2018.3.0b8, 2018.3.0b10, 2019.1.0a9
Not reproduced on 2018.2.16f1, 2018.3.0a1, 2018.3.0b7
Regression introduced in 2018.3.0b8

notes:
- Is known to also cause memory leaks

Response avatar

richardkettlewell

Jan 18, 2019

We are working on this issue right now as a priority.

Comments (68)

  1. 22204384958ada0286352f83fd2dbb97?d=mm

    myxolobe

    Jan 19, 2019 20:36

    Confirmed that this issue still exists in 2018.3.2f1

  2. 95cfe7fd4e884b0551712b76f8de72be?d=mm

    SG_roboryantron

    Jan 18, 2019 22:22

    We actually hooked into the PlayerLoopSystem and disabled all particle related loops and saw the issue go away.... but we don't have particles. It is a useful high level switch to turn particles off so non-art devs can keep moving.

  3. 4d77ef840b5f005369801b7c2da69234?d=mm

    RWeijermars

    Jan 18, 2019 17:11

    Thx for thx for the update Richard. Any news on if a possible solution has been found?

  4. 4d77ef840b5f005369801b7c2da69234?d=mm

    RWeijermars

    Jan 18, 2019 13:44

    Thx for thx for the update Richard. Any news on if a possible solution has been found?

  5. 85f86a16c477dca3280a348adaf8d591?d=mm

    dimitris_baud

    Jan 18, 2019 11:26

    Yes, you are not alone. You can tell by the number of votes.

    My current workflow is:
    - Disable all particle systems and work on the rest of the project fine
    - If I need the particle systems, restart Unity after 2 times I hit Play, when RAM usage is around 30GB (!)

  6. 7f13c2609ade1034b0eab69f8e485e5a?d=mm

    PatrickVRNerds

    Jan 18, 2019 09:09

    Pew.. finally found a thread about this. It's really dramatically - if we start playmode once, everything seems to be fine. If we start playmode a second time our memory usage increases until it's full. We can't do anything right now, computers are crashing when we are closing a build after like 10 minutes runtime. High prio on this please!

  7. Ffbed214ed2c3a124dcd4811eb0f99f9?d=mm

    FenceGuy

    Jan 17, 2019 22:12

    Still occuring in 2018.3.2f1 unfortunately. Expected as the release notes didn't suggest otherwise though.

  8. Ced9fac7af09d8933b3f06d8d5111426?d=mm

    eyalfx

    Jan 17, 2019 19:30

    has anyone tested on 2018.3.2 ?
    I'm using 2018.3.1f1 and really hoping for a fix soon.

  9. 4103a22c52b0d724829bb03fa307b56b?d=mm

    jonagill_ag

    Jan 17, 2019 18:48

    @ApeSoup: Well, that's disappointing. Thank you for verifying that.

    @RichardKettlewell: Is there an estimate on when this issue might be fixed? I was hopeful we might see it patched in 2018.3.2, and while that build has a lot of good fixes in it, I don't see VR bugs mentioned anywhere.

  10. B181d45c4808017ecd804d852fa5472b?d=mm

    chatrat12

    Jan 17, 2019 15:07

    One of the reasons I wish unity was open source is because this would be posted as an issueo on GitHub and we all could have helped find a temporary solution while waiting for the official one. Sucks this one does under the radar for 2 months. Glad to hear the fix is under way.:D

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.