Search Issue Tracker

Duplicate

Votes

6

Found in

2017.1.0f3

Issue ID

940696

Regression

No

VideoPlayer performs very poorly on a device when "Multithreaded Rendering" is enabled

Video

-

Reproduction steps:
1. Open the attached project;
2. Check if "Multithreaded Rendering" is enabled in Player Settings;
3. Build the scene "video" on a device;

Actual result: the video is very laggy.
Expected result: the video should be shown without any disturbances.

Note: if "Multithreaded Rendering" is disabled, the video is shown correctly. Also, the bug does not appear in Editor and standalone.

Reproduced with: 5.6.3f1, 2017.1.0p3, 2017.2.0b6, 2017.3.0a3

Note#2: the video is stopped at all in 2017.2 and 2017.3 versions.

Devices under test:

Google Pixel XL*, OS:8.0.0, CPU:arm64-v8a, GPU:Adreno (TM) 530, Build:google/marlin/marlin:O/OPP2.170420.019/4021594:user/release-keys

Google Nexus 5X*, OS:7.1.2, CPU:arm64-v8a, GPU:Adreno (TM) 418, Build:google/bullhead/bullhead:7.1.2/N2G47W/3938523:user/release-keys

Verizon SM G930V*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 530, Build:Verizon/heroqltevzw/heroqltevzw:7.0/NRD90M/G930VVRU4BQA2:user/release-keys

Amazon KFMEWI (Fire HD 8 (2015))*, OS:5.1.1, CPU:armeabi-v7a, GPU:PowerVR Rogue G6200, Build:Amazon/full_thebes/thebes:5.1.1/LVY48F/32.5.6.3_user_563231720:user/release-keys

  1. This is a duplicate of issue #931038

    [Android] VideoPlayer stuttering and dropping frames

Comments (1)

  1. Tillmania69

    Aug 15, 2017 18:04

    I have this same issue in iOS. There is no Multhreaded Rendering option however.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.