Search Issue Tracker

Fixed in 2018.1.X

Fixed in 5.6.X, 2017.1.X, 2017.2.X, 2017.3.X



Found in


Issue ID




[Android] VideoPlayer stuttering and dropping frames



How to reproduce:
1. Open stripped project from OC
2. Deploy app to device
3. Click 'Breathing'
4. Click 'What are the benefits?'
5. Click on the video 'play' icon
-- Observe abysmal video performance

Reproduced on: 5.6.2f1, 5.6.2p4, 2017.1.0p1, 2017.2.0b4, 2017.3.0a1

Issue cause: Multithreaded Rendering, with Multithreaded Rendering disabled video plays smoothly.

Devices under testing:
Samsung SM G900F (Galaxy S5)*, OS:6.0.1, CPU:armeabi-v7a, GPU:Adreno (TM) 330, Build:samsung/kltexx/klte:6.0.1/MMB29M/G900FXXS1CQC1:user/release-keys
Samsung SM G950U*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 540, Build:samsung/dreamqltesq/dreamqltesq:7.0/NRD90M/G950USQU1AQC8:user/release-keys
Verizon SM G930V*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 530, Build:Verizon/heroqltevzw/heroqltevzw:7.0/NRD90M/G930VVRU4BQC5:user/release-keys
Xiaomi MI NOTE Pro*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 430, Build:Xiaomi/leo/leo:7.0/NRD90M/7.7.13:user/release-keys

Fixed in: 5.6.4p3, 2017.1.2p3, 2017.2.0p3, 2017.3.0b9, 2018.1.0a2

  1. Yury-Habets

    Aug 25, 2017

    Our developer has identified the issue is caused by Multithreaded Rendering option enabled. Disabling it may be a workaround for you until we get a proper fix.

Comments (55)

  1. fuck_world

    Mar 14, 2023 04:03


  2. hossenshovon1

    Feb 17, 2022 21:10

    No need to do anything. Check in the statistic, if you see your game has 30 fps, then try to export the video which you want to import in unity with 30 fps, That will solve this issue.

    if your game getting 60fps , then a 30 fps video will run smoothly.

    this issue is with your video file. not with unity. I saw all this comments in this issue tracker. nothing helps, but when i menually try with the fps, It works like a (Forget what to say). Btw enjoy

  3. HmkSoftLtd

    Feb 16, 2022 19:54

    Uncheck Skip on Drop on video player. and disable multithreaded rendering for lagging

  4. Ambigate

    May 31, 2021 09:41


    with Unity >= 2018 you can still have this problem in Unity on Android. Maybe also in ios.

    The solution can be on two points.

    1. Deactivate Multiplayer Rendering as descriped (Here it is possible the problem ist solved in newer unity versions )

    2. This Problem ca be appear if the video is not exported with specs unity3d supports. Maybe wrong framerate or file format. Change the videoproperties to the specs unity needs.

    Hope it still helps in 2021

  5. paulksi

    Oct 13, 2020 19:14

    Another samsung s5e user, i confirm it stops, also s5e gyroscope is very unstable, the only way i found is using av pro plugin

  6. IARI

    Sep 10, 2020 10:59

    This issue is still present in unity 2019.3.
    Also there are apparently bots posting spam in the comment of this issue tracker - all of this doesn't come across as serious

  7. Constantin_Suman

    Mar 05, 2020 10:55

    Still an issue:
    Samsung Galaxy S5e
    Unity 2019.2.6f1

    But works fine with:
    Samsung Galaxy S3

    Multi-threading was already disabled.

    Tried but did not work another solution, setting the mp4 videos to these settings:

    Override for Android ✓

    Transcode ✓
    Dimensions Original (330x1018)
    Codec H264
    Bitrate Mode High
    Spatial Quality High Spatial Quality

  8. Constantin_Suman

    Mar 05, 2020 10:45

    Still an issue:
    Samsung Galaxy S5e
    Unity 2019.2.6f1

    But works fine with:
    Samsung Galaxy S3

  9. Ham1ton

    Dec 29, 2019 21:52

    Can this issue be opened again once it's closed or do we have to submit a new one?

  10. nsmith1024

    Dec 12, 2019 15:16

    Multi-threading was already disabled problem still exists. im using Unity 2018.3, VideoPlayer keeps stuttering every 2 seconds, stopping and going, both video and audio on android keeps stopping, its not usable at all, not even a little bit.

    Its as if something is hogging the CPU, or network get stuck and nothing to play for a second, but the game scene has nothing in there except the VideoPlayer and the player itself.

    Other video players work fine on the same video, but they dont have AudioSource like the Unity VideoPlayer does, i need the AudioSource, or else i would have dropped this player long ago.

    Is Unity Company ok with having VideoPlayer that doesnt work on Android when so many developers out there making android apps? So many complaints (including mine) cant be wrong!

    Right now im stuck because player dont work!

    PLEASE FIX!!!!!!!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.