Search Issue Tracker

Fixed in 2020.1

Votes

0

Found in

2019.2.0a1

2019.3.0a1

2019.3.0a12

Issue ID

1176212

Regression

Yes

[VCS] Undescriptive prompt is thrown when trying to delete assets while Version Control is disconnected

Version Control

-

How to reproduce:
1. Create a new project and open it
2. In the Project Window create a new empty script
3. Go to "Edit" -> "Project Settings" -> "Editor" and change your Version Control mode to Perforce
4. Without inputting any Perforce credentials, try to delete the newly created empty script
5. Observe the error/prompt that shows up

Expected result: the prompt is descriptive on why the user can't delete the files. Alternatively, if the Editor loses previously fine connection it tries to reconnect VCS and then throws a different error if it fails to do so.
Actual result: an undescriptive "Some assets could not be deleted. Make sure nothing is keeping a hook on them, like a loaded DLL for example." error prompt is thrown.

Reproducible in: 2019.3.0a12, 2019.2.1f1
Not reproducible in: 2019.1.14f1, 2018.4.6f1, 2017.4.31f1 (In these versions the file still cannot be deleted and a "Cannot delete files in offline mode" error is thrown. The "Cannot delete" prompt doesn't show up though)

  1. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in: 2020.1.0a12

Comments (1)

  1. A4a7633be1f11a5e5840bb0cb400b17b?d=mm

    stephaniesteph86

    Jun 21, 2020 17:59

    I experienced this prompt, as well, and I didn't know what to do. Hopefully, the https://www.topdissertations.org/edugeeksclub-com/ people will provide me a solution to this problem soon. That would make me happy.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.