Search Issue Tracker


Fixed in 2022.3.9f1, 2023.2.0b7, 2023.3.0a1



Found in





Issue ID




[URP] After enabling URP Dynamic Resolution the Game View is not rendered



Steps to reproduce:
# Download attached project and open in Unity
# Open scene SampleScene
# Make sure the Game View is active
# Select the Main Camera in the Hierarchy and enable “URP Dynamic Resolution” checkbox
# Observe black Game View


Reproduced with:

2022.1.0b1; 2022.1.24f1; 2022.2.8f1; 2023.2.0a6

Not reproduced with:

2021.1.28f1; 2021.2.19f1; 2021.3.20f1; 2022.1.0a1; 2022.1.0a10; 2022.1.0a16

Regressed in: 




In 2023.1.0a1 - 2023.1.0b5 not allowed to even enable the “URP Dynamic Resolution” checkbox for some reason.


Device under testing:

MacBook Pro (16-inch, 2021), CPU: Apple M1 Max, Memory: 64 GB, macOS: Monterey 12.6 (21G115)

Comments (9)

  1. andreiagmu

    Oct 28, 2023 18:23

    Just a correction for my previous post, when I listed my issues with 2023.2.0b15:

    *and much slower shader variants compilation time.

  2. andreiagmu

    Oct 28, 2023 18:18

    Is there any chance of backporting this fix to 2023.1? Just like how it was backported to 2022.3.9.
    I want to use Unity 2023 for the new URP features, but this bug still happens on 2023.1.18.

    I tried 2023.2.0b15. URP Dynamic Resolution works there, but I had lots of other issues on this beta compared to 2023.1.18: some incompatible assets (mainly MicroVerse), bigger addressable/build sizes, and much slower shader compilation time.

    I found 2023.1.18 to be an amazing version, it felt very stable. The only thing missing for me is this URP Dynamic Resolution bugfix.

  3. TheStarWarrior

    Aug 26, 2023 17:25

    Having the same issue, just encountered this one while following Code Monkey's Unity Overview Course on Udemy. Guess you can't do dynamic resolution with URP until Unity fixes this.

  4. greg-harding

    Jul 26, 2023 03:31

    Additionally, on macOS if the camera also has 'Opaque Texture' set to 'On' then the scene does not render, the game view does not render, the console is full of errors and Unity needs to be restarted.

  5. JohnHacker

    Jul 12, 2023 09:01

    This is a high priority issue indeed, and it has been broken for 9 months, since 2022.1. It would be great to have someone at Unity say something about the status of this issue. Thank you!

  6. james_work

    Jul 07, 2023 01:34

    It's been four Months since this ticket was opened; are there any updates regarding this?

    Not using dynamic resolution isn't a suitable workaround. The feature simply doesn't work - surely this is a high priority issue?

  7. JohnHacker

    Jun 20, 2023 07:28

    Dynamic resolution for URP was broken at some point in 2022 and it hasn't worked again since then. Unity team, could you please update the status of this problem? Thank you.

  8. Longtianmu

    Jun 11, 2023 08:49

    I have tested this option on Unity 2022.03.0f1, and this cause tons of error log in console.
    The same project could run smoothly on Unity 2021 or 2020, I believe the problem is related to Dynamic Resolution when using Metal,Vulkan or DX12.
    Even using Render Texture may be affected by this problem, the solution is switch Render target to None, disbale Dynamic Resolution and then switch back.

  9. andreiagmu

    Jun 08, 2023 08:09

    I have this issue with "Allow Dynamic Resolution" enabled on 2022.3.1f1, with Graphics APIs Direct3D12 (Windows) and Vulkan (Android).

    From my tests, this issue doesn't happen on 2021.3.26f1.
    This issue also doesn't happen with Direct3D11 (Windows) and OpenGLES3 (Android) on 2022.3.1f1.
    So, it seems like a Direct3D12/Vulkan-related issue in Unity 2022/URP 14.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.