Search Issue Tracker

Won't Fix

Votes

3

Found in

2021.3.8f1

2022.1.14f1

2022.2.0b6

2023.1.0a8

Issue ID

UUM-13134

Regression

Yes

Unity Editor is rendered without the toolbar icons when using it on old hardware with integrated GPU

--

-

How to reproduce:
1. Open the user-attached project or create a new one
2. Observe the Editor

Expected result: All the icons are rendered
Actual result: There are missing icons

Reproduced with: 2021.1.28f1, 2021.3.8f1, 2022.1.14f1, 2022.2.0b6, 2023.1.0a8
Not reproduced with: 2020.3.39f1, 2021.1.27f1

Reproduced on: Windows 7, Windows 8, Windows 10

Note: This issue is happening only on the old hardware, specifically on all of the 2nd generation of Intel CPUs (i3, i5, and i7) and Celeron B800, without dedicated GPU, both in laptops and desktops. The issue is not reproducible if you set Unity Editor to use integrated GPU when it still has a dedicated GPU.

  1. Resolution Note:

    We don't have access to hardware in order to reproduce, and thus fix this or assign it to whomever caused the regression.

    DX11 backend has had no changes during that time so it's something else in the engine that has changed. But we cannot say what without being able to bisect.

Comments (4)

  1. bignk05

    Dec 02, 2022 18:52

    I had the same problem with 2021.3.13f1. My workaround was to change my build platform in "File>Build Settings". Choose any other platform you got on the left (eg. WebGL) and press "Switch Platorm". After switching to WebGL the icons suddenly appeared. It seems like the Unity Editor reloaded the icons somehow.

    Note: The "Switch Platform" Action might take several minutes to perform

  2. zukinet

    Nov 15, 2022 07:11

    I have tried Unity 2022.2.0b14 but i toolbar icons are still missing.

    any idea?

  3. Developezbr

    Oct 30, 2022 02:15

    well, so as not to confuse things I recommend it for small projects, because it is in beta it may contain bugs to be solved, I use it only to study, so if you are looking for something in its latest version, even if it is beta, maybe you be useful.

  4. Developezbr

    Oct 30, 2022 01:56

    It's happening to me too, above version 2021, I downloaded beta 2022.2.0b2 and it was the only version I tested and it's rendering normally. so I recommend downloading the beta 2022.2.0b2, until the next versions have a fix. :)

Add comment

Log in to post comment