Search Issue Tracker

Fixed in 5.5.2

Votes

4

Found in

5.5.0p3

Issue ID

864122

Regression

Yes

TLS ALLOCATOR ALLOC_TEMP_THREAD error caused by particle systems

Visual Effects - Legacy

-

Steps to reproduce:
1. Download and open the attached project
2. Drag the Fireworks prefab into the scene
3. Observe the console

Expected result: no errors
Actual result: ERROR IN TLS ALLOCATOR ALLOC_TEMP_THREAD

Reproduced on: 5.5.0p3
Not reproduced on: 5.4.4f1, 5.6.0b3

Notes:
-in this case, caused by the Fireworks prefab from standard assets

Comments (67)

  1. 62dcc3735ae58ac67dcb86e2d9fe6d7a?d=mm

    WagDan

    Apr 20, 2017 08:06

    Thank you Hakuhonoo, I had this same issue since updating to 5.6 building to iOS. I tried to remove all the particle assets from the Standard Assets which didn't work, deleting the whole standard asserts did work. You saved me a lot of debugging.

    I wonder which asset is the cause.

  2. 12d24a56054d37da3006b69c9602e47a?d=mm

    the_mr_matt

    Apr 15, 2017 09:25

    I'm also getting this error when I build for iOS.

  3. C22bb55eb950360bd5f7ed5f98208369?d=mm

    dhanpreet

    Apr 11, 2017 10:33

    Im also getting this issue in 5.6.0f.....when i build for ios

  4. E58f46e570524bcf1a5fbbb36d469534?d=mm

    mattm401

    Mar 25, 2017 19:26

    I am still getting this issue in 5.5.2.

  5. 6680674eac3a35e2ab2a11a4626de9e9?d=mm

    Quantme

    Jan 30, 2017 03:26

    Good but... where/when is/will-be 5.5.2 available?

  6. A523db7f9ba19997666430eb848e0420?d=mm

    QuantumRyan

    Jan 10, 2017 21:25

    I see a similar issue with 5.5.0f3 on two different Windows computers.

    I don't see any errors unless I have the Fireworks GameObject selected in the Hierarchy, then the Console is flooded with "Assertion failed on expression:" errors followed by the ERROR IN TLS ALLOCATOR...

  7. 25f97c7995f5b461e5702db47bb50643?d=mm

    Hakuhonoo

    Jan 02, 2017 14:12

    I have this issue too. It appears to have same result even without particle system on a scene. Having standard packs added o a project (not sure which one) is enough to reproduce this bug.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.