Search Issue Tracker

Fixed in 2019.1.X

Fixed in 2018.3.X



Found in


Issue ID




Tiles can't be deleted without deleting the whole Tilemap when the Tiles have lost it's Tile Base or Sprite



How to reproduce:
1. Open the attached project
2. Go to the Hierarchy window -> Grid -> disable "RoughDirt" and "Walls" GameObjects
3. Go to Tile Palette window -> make sure that Active Tilemap is Dirt
4. Select Erase brush and try to delete Tiles in the Sene view

Expected: Tiles without Tile Base or Sprite gets deleted
Actual: Tiles can't be deleted without deleting the whole Tilemap

Reproduced on: 2017.4.12f1, 2018.1.9f2, 2018.2.11f1, 2018.3.0b4, 2019.1.0a3

Note: Couldn't test on 2017.2 because of project crashing on load
Re-adding Tile Base to the Tile creates a new tile on top of the old one

Comments (7)

  1. jlbaker2779

    Nov 17, 2021 18:58

    2022.1 - Randomly can't delete tiles on an isometric grid. The issue seems to be the sorting groups. Changing the order a couple of times breaks it free and you can delete again.

  2. magnate

    Apr 03, 2020 17:15

    I have Unity 2019.3.7f1 and a problem has still :(

  3. pankhard159

    Nov 13, 2019 07:18

    Still not fixed 2019.2.6f1

  4. vifyrv

    Oct 24, 2019 19:22

    I am having this problem as well.

    Unity version 2019.1.9f1

    I can't delete any of the tiles around my character for some reason.

  5. mikaxms

    Jul 10, 2019 14:06

    I renamed the folder in which the sprites were placed. It worked fine for a while and then I couldn't delete the tiles anymore. The little tile selector square was also blue instead of the normal white. After restarting the project everything went back to normal.

  6. mikaxms

    Jul 10, 2019 14:02

    I'm now also having this bug in 2019.1.8f

  7. JoeC01

    May 24, 2019 06:44

    this isn't fixed in 2019.1.3f1 or a new similar bug has appeared

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.