Search Issue Tracker

Not Reproducible

Votes

7

Found in

5.4.0f2

Issue ID

816455

Regression

No

[TheLabRenderer] Shader fails to open source file error when it is attached to object at certain conditions

Shaders

-

How to reproduce:
1. Create a new project
2. Open Asset Store and import The Lab Renderer project
3. Create a new folder and move TheLabRenderer folder inside of it
4. Create a new Material in the project (Assets-> Create-> Material)
5. Create a new game object in the scene
6. Make sure that scene view is open
7. Draw material to created game object
8. Change Standard shader to Velve/vr_standard
9. It becomes pink and there is an error in the Console "Shader error in 'Valve/vr_standard': failed to open source file: 'vr_utils.cginc' at line 149 (on d3d11)"

Note: If you firstly check the shader on the material while TheLabRenderer folder is in the root of the project it will continue working just fine while replicating these steps.

Not Reproducible: we can no longer reproduce the bug, the shader is out of date and no longer compiles

Comments (9)

  1. Ef25945a041a7e043f7c0ccfd0a41834?d=mm

    gw1108

    Mar 05, 2018 01:39

    Similar error happened to me with UnityChan plugin. All of UnityChan's shader's were spitting out errors. Right click reimport fixed it for me as well. Unity 2017.3.0f3.

  2. 1e15119bc4ebdcbf4ed53e005a4f3c18?d=mm

    calemb

    Jan 24, 2018 16:38

    Same on other imported package. 2017.2 - Thanks for help with reimporting - work for now

  3. 451727943ea782d2159b1ea5ccebe11f?d=mm

    markgrossnickle

    Jan 24, 2018 00:10

    I am able to reproduce this in 2017.3.0f3 but re-importing the shader fixes it so low priority.

  4. A3cad2a42dad4286e60306c3b77c54f9?d=mm

    FUBAR2077

    Dec 20, 2017 12:07

    maybe "Velve/vr_standard" Velve is an issue ;D

  5. F0a3bb83ad222e04dc7750bfc671816f?d=mm

    Cover-Club-Media

    Nov 29, 2017 17:21

    Clicking on the affected shader and choosing reimport after moving them to a new folder seems to fix the issue.

  6. F0a3bb83ad222e04dc7750bfc671816f?d=mm

    Cover-Club-Media

    Nov 29, 2017 17:13

    Finding this in 5.6.1f1 when moving shaders after import. Initially working fine.

  7. C4e43e794098a0c99fce0c291748e720?d=mm

    RogueCode

    May 16, 2017 09:20

    I'm getting this in 5.6.1f1 building for Xbox.

  8. A4095b1a6ed7b0cbc9b9b4d3f11ef8e3?d=mm

    zxkne

    Apr 11, 2017 09:04

    Also, for those who faced with a similar issue: reimporting of shaders fixes the error.

  9. A4095b1a6ed7b0cbc9b9b4d3f11ef8e3?d=mm

    zxkne

    Apr 11, 2017 07:51

    It seems that this issue is relevant to not only TheLabRenderer, but to any other package too. I faced the same error with my asset. Reproduction steps are the same: move the asset right after importing.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.