Search Issue Tracker

Fixed

Votes

0

Found in

2019.2.0a8

Issue ID

1136199

Regression

Yes

The Error "Copying assembly from Temp to Library failed" appears when updating the project to 2019.2.0a8 version

Scripting

-

To reproduce:
1. Open attached project "prof"
2. Open it with Unity 2019.2.0a8
3. Close and reopen the project with 2018.2.0a8 and check the console

Actual result: error appears in the console
Expected result: there should be no error.

Reproduced with: 2019.2.0a8
Can't reproduce with 2019.2.0a7

Error:
Copying assembly from 'Temp/com.unity.multiplayer-hlapi.Runtime.dll' to 'Library/ScriptAssemblies/com.unity.multiplayer-hlapi.Runtime.dll' failed

  1. Response avatar

    Resolution Note:

    Should be fixed in HLAPI package v 1.0.2

Comments (19)

  1. 3a604a80369a89f0e6618e53ff6486e1?d=mm

    OctaLuna123

    Nov 16, 2020 14:35

    Hola Buenos días, yo uso la versión de Unity 2019.4.14f11; primero usaba una versión de Unity 2019.2.0f1, no tuve problemas hasta que cambie de posición mis proyectos, y me aparecía el error Copying assembly from 'Temp/Assembly-CSharp.dll' to 'Library/ScriptAssemblies/Assembly-CSharp.dll' failed, busque como solucionarlo primero reimporte los Sprites y Scripts, y me función pero cada cierto momento me aparecía el error y me molestaba, luego seguí buscando en Internet mi error y la otra opción era que tenia un malware y examine mi equipo con malwarebytes y no tenia ningún malware luego use Eset para examinar mi equipo y no tenia nada, luego pensé que era por la versión de Unity que tenia y me actualice a la vercion 2019.2.0f1 y no tuve problemas hasta que programe un Script y me apareció nuevamente el problema, reimporte de nuevo pero no funciono y no puedo trabajar con ese error por que no se va.
    Me encanta programar en unity y es mi programa favorito para crear juegos pero me encontré con este problema y quisiera que me pudieran ayudar
    Gracias

  2. 76ea5c2b1d18e8110c6b7d863ac05c4e?d=mm

    UDN_e7666fec-2cb5-4cfe-a678-e5e5ba6ec4ce

    May 16, 2020 00:40

    Turn off your antivirus software,Not realizing it caused me a lot of trouble.
    关掉你的杀毒软件。

  3. C9ca433d100c707ac6f631fde0477119?d=mm

    Yo030

    May 15, 2020 04:08

    Unity 2019.1.7.f1
    I think I may have found the solution, although I am not sure what it was, but this is what I did:
    I went to Window > Package Manager
    I installed Multiplayer HLAPI
    installed XR Legacy Input Helpers (The one that caused me this error)
    Removed XR Legacy Input Helpers
    installed XR Legacy Input Helpers (Yes, I did this twice)
    Removed XR Legacy Input Helpers
    I opened Android Studio and installed API 23 & 24, after it was complete, I went back to Unity
    I reinstalled XR Legacy Input Helpers
    And the error was gone. Hope it helps someone.

  4. Ab89ad3532a88e9bed4aa6a31762dd0f?d=mm

    alstovbur

    Apr 17, 2020 18:21

    Actual for 2019.3.10f1

  5. 68374e98f3c43615ef06417ea95065f7?d=mm

    Marcos-Elias

    Mar 30, 2020 14:15

    Happened here in 2019.3... after upgrading the Post Processing effects package.

    Removing that multiplayer package solved it, I don't know why. It’s unbelievable how unstable Unity became, lots of hours lost each update... Seems a random problem with the package manager.

  6. 17e7541e33a4d3232b4686558c1e7b14?d=mm

    aerospacevitd

    Nov 26, 2019 15:37

    This issue continues to persist and none of the suggested fixes work for us.

  7. 23ab754a323dfb9bbfe513ac7707c821?d=mm

    Dami-Juana

    Oct 21, 2019 13:36

    I had the same error,
    Update the multiplayer package worked for me on 2019.2.5

  8. 2f347c0df6eb9609edab70bd144a9def?d=mm

    dienat

    Oct 18, 2019 22:49

    Same error , i get these using 2018.3:
    Copying assembly from 'Temp/Obi.dll' to 'Library/ScriptAssemblies/Obi.dll' failed
    Copying assembly from 'Temp/Unity.Postprocessing.Runtime.dll' to 'Library/ScriptAssemblies/Unity.Postprocessing.Runtime.dll' failed
    Copying assembly from 'Temp/Unity.TextMeshPro.dll' to 'Library/ScriptAssemblies/Unity.TextMeshPro.dll' failed

  9. 439d26e9716b9e5d12401f26a92caa88?d=mm

    casoich-DDI

    Oct 08, 2019 16:43

    I'm going to comment this here, because I _THINK_ I found the culprit/fix. At least, it's still working for me...

    I went into `Preferences->External Tools` and increased `Maximum JVM Heap Size, MBytes` from 4096 to 6000.

    I'll report back if it's not actually a fix, and hopefully others will try it and report too.

  10. 644a451a0f827335e5db3e9f716645b7?d=mm

    mccann

    Sep 30, 2019 14:39

    Issue happened on 2019.2.5f1. I removed the multiplayer package (wasn't using) and resolved the issue.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.