Search Issue Tracker

Not Reproducible



Found in


Issue ID




[Terrain Tools] Texture Layers will occasionally disappear from the Terrain Inspector



Note: The repro rate on this issue is fairly low. Listed repro steps are potential repro for triggering this issue.

Potential Steps:
1. Select a terrain
2. Go to different tools from the drop down e.g. Paint Texture -> Sculpt Noise -> Sculpt Terrace -> ... -> Paint Texture
3. See error in console

NullReferenceException: Object reference not set to an instance of an object
UnityEditor.Experimental.TerrainAPI.PaintTextureTool.UpdateLayerPalette (UnityEngine.Terrain terrain) (at D:/UnityProject/_CDS/stw-20-2-terrain-sample-content/TerrainTools/com.unity.terrain-tools/Editor/TerrainTools/PaintTextureTool.cs:754)
UnityEditor.Experimental.TerrainAPI.PaintTextureTool.OnInspectorGUI (UnityEngine.Terrain terrain, UnityEditor.Experimental.TerrainAPI.IOnInspectorGUI editContext) (at D:/UnityProject/_CDS/stw-20-2-terrain-sample-content/TerrainTools/com.unity.terrain-tools/Editor/TerrainTools/PaintTextureTool.cs:344)

Comments (10)

  1. rvndudz77

    Oct 12, 2023 19:40

    Once you created a palatte, you should save it before move into another panel or interface. That is the fix!

  2. jasonrdunne

    Apr 19, 2022 00:11

    This has been a problem for me for years. I get back on unity in 2022 and it's still a problem. Come on! 2020.3 LTS.

  3. ngclcs

    Mar 15, 2022 14:20

    Just happened in 2020.3.29

  4. Zee-Play

    Feb 20, 2022 00:01

    Still present in 2020.3.19f1 LTS

  5. chatie25

    Jul 12, 2021 14:35

    I have the same error all my texture brush layers are no longer there, even the actual LAYER itself.
    This is Unity 2020.3.9f1 version.

    Any help or suggestion I would appreciated it.


  6. FatPlankton

    Jun 24, 2021 10:14

    Also getting this exact error in my current project.

    2020.3.11f1 LTS Terrain Tools v3.0.2 preview 3

    Everything works fine just after opening the project, however once I run the project the error occurs upon selecting a terrain. I have deleted all existing terrains and created new terrains but the error still occurs. Error disappears upon restarting editor.

    It might be worth pointing out that this project was upgraded from 2020.1.3f1

  7. CraigHubbard

    Jun 06, 2021 12:33

    Happening in 2020.3.7f1 LTS

    Occurs frequently but not every session. Haven't figured out a clear repro yet.

    Fixable by restarting the editor.

  8. unity_YXM3VYBz7eSrkg

    May 18, 2021 22:11

    This is still occurring for us. It's worth noting that the repro rate is not 100%.

  9. Danielhall78

    Apr 18, 2021 20:19


  10. martlost

    Mar 08, 2021 03:18

    I'am having same issue. 2020.1.10f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.