Search Issue Tracker

Fixed in 5.3.0

Votes

0

Found in

5.2.0b6

Issue ID

719367

Regression

Yes

[SceneView]Can't select objects in scene view without dragging around it

Scene/Game View

-

To reproduce:
1) Open attached project and the scene inside of it
2) Try selecting any object in scene view by clicking on it. Notice that such selecting doesn't work
3) Change project to gamma mode (edit -> project settings -> player -> Rendering -> Color Space
4) Resize scene view slightly to get proper repaint
5) Try picking. Should work now.

Comments (35)

  1. 07d02f6213ecc66ec44261639f470590?d=mm

    krides

    Apr 21, 2016 10:37

    I can't believe that this is still happening in 5.3.4. It is not fixed, our level design is completely blocked by this issue, and none of the solutions online (including the one above) solve anything.

  2. 7a3cc82ed1594c8851a04bf058498d42?d=mm

    ChrisLee

    Apr 18, 2016 20:39

    I have v5.3.4f1 on Windows too and i have the same problem... i have deleted my water. After that i was able to select some probs but not everyone. Have to select it in the hierarchy.

  3. Ada242cbddea25975f8c5eb0fcc7f46a?d=mm

    CameronLewis

    Apr 17, 2016 13:25

    Still happening in v5.3.4f1 on Windows.

  4. 7e663aa93df808a4498116cb43f75778?d=mm

    Zarod

    Apr 10, 2016 13:31

    OXEREN, You Saved me. Disabling the Reflection in Edit Mode worked :)

  5. 54b0da3336ae4ae3d6167f82c00b6ccb?d=mm

    Oxeren

    Apr 01, 2016 09:46

    Had the same issue after updating to 5.3.4, as people are saying it was caused by water reflections. The solution that does not include changing water type is to remove [ExecuteInEditMode] line from the water script, though there will be no reflections in the scene view.

  6. 22eea4cfc52b681e3852f60cfd7906f2?d=mm

    ramsicle

    Mar 30, 2016 23:29

    Yep I'm with Pherim, the wateProDayTime caused the issue for me. Changed the Water Mode setting to Simple and the problem went away... Unit 5.3.4

  7. 4f1fac4175986313d0bd0d13bc9303f2?d=mm

    Laious

    Mar 24, 2016 06:03

    Yep... Still happening in 5.3.4

  8. 29420722acc15cea5e6cf86fba6c511a?d=mm

    FalconCGN

    Mar 21, 2016 17:15

    The problem still exists in 5.3.4f1

  9. E875f6a219d5e498d6f820dd3272032b?d=mm

    Pherim

    Mar 21, 2016 13:54

    Even more specific, it appears to be the reflection that causes it. Changing Water mode to simple works as well.

  10. E875f6a219d5e498d6f820dd3272032b?d=mm

    Pherim

    Mar 21, 2016 13:48

    Ok, I had just experienced the same issue for the first time, after updating to 5.3.4. and after all the solutions I found didn't work for me I began deleting objects from the affected scene one by one and found that it worked again after I deleted the water plane. It was the WaterProDaytime prefab from the standard assets. Specifically, the water script component causes the issue. Disabling it makes objects clickable again.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.