Search Issue Tracker

Fixed in 5.3.0

Votes

0

Found in

5.2.0b6

Issue ID

719367

Regression

Yes

[SceneView]Can't select objects in scene view without dragging around it

Scene/Game View

-

To reproduce:
1) Open attached project and the scene inside of it
2) Try selecting any object in scene view by clicking on it. Notice that such selecting doesn't work
3) Change project to gamma mode (edit -> project settings -> player -> Rendering -> Color Space
4) Resize scene view slightly to get proper repaint
5) Try picking. Should work now.

Comments (35)

  1. 1d1ba1ccd746ff62fe766740aadc5cbf?d=mm

    Ultramattt

    Oct 04, 2016 20:28

    I have a fix for the problem. But its ugly! If you delete an object in the scene and then undo the delete you can now drag and select it again. So select everything in your Hierarchy list and delete it then Undo (obviously there is some inherent risk in doing this but it worked for me). My programmer believes that it has to do with the Scene Graph and deleting objects and then Undoing the delete refreshes the scene graph for that object.

  2. 6e53400acf664d8e09410836af128733?d=mm

    StickTick

    Sep 09, 2016 11:35

    For some reason this happens when i've typed something in the hierarchy search field.

    Let's say you have a lot of objects with the name "building" in them. Type "building" in the search field, and then press X on the right side of the search field to get back to normal hierarchy view.

    Now you can select these gameobjects the normal way.

  3. F4333a8ece5170bbd1f2db457b72d567?d=mm

    BooNonMooN

    Aug 31, 2016 13:01

    A small workaround that worked for me was to give the water plane a layer and then to disable this layer in the editor.
    It's not pretty but you can still work on your project without recreating it.

  4. 4db311bf57048ffe358f9e83633d5807?d=mm

    pietwelve2

    Aug 21, 2016 02:10

    thanks OXEREN for the water tip ! Just masking the water layer works for me ...

  5. 3a44e495008a1738bab334ea618ee55b?d=mm

    tobiasforsling

    Jul 25, 2016 08:20

    Confirmed, Oxerens solution works!

    Thanks!
    Saved a whole bunch of pain for our team!

    "Oxeren

    Apr 01, 2016 09:46

    Had the same issue after updating to 5.3.4, as people are saying it was caused by water reflections. The solution that does not include changing water type is to remove [ExecuteInEditMode] line from the water script, though there will be no reflections in the scene view."

  6. 59ec1416410c364b456789a84ff464b2?d=mm

    jcikoratic

    Jul 15, 2016 15:18

    Ditto water mode to simple solved the problem

  7. 4db311bf57048ffe358f9e83633d5807?d=mm

    pietwelve2

    Jun 23, 2016 18:40

    Hi, I've have the problem in 5.3.5

  8. 42bfe77a50e4442a97c8f0661453918d?d=mm

    Wolfram

    Jun 08, 2016 17:08

    Status: NOT fixed in 5.3.x! Still an issue in 5.3.5f1! (maybe it works for the project attached to the bug report, but it does NOT work for the general public!)

    @Oxeren: THANKS! This fixed it!

    @Unity: please re-open. please take a look at the Water.cs StandardAsset and what it does when "[ExecuteInEditMode]" is active.

  9. 329735e4cbc5e5087d5a7f4aea5acf21?d=mm

    TUNev

    May 07, 2016 17:02

    I can't select anything. Have to select in the hierarchy. Which is annoying when you have 32 rocks that look very similar, so you have to guess at random. This software is unusable. I have spent an hour trying to figure out what I am doing wrong, but I am coming to the conclusion that it is a major bug that Unity should fix.

  10. 329735e4cbc5e5087d5a7f4aea5acf21?d=mm

    TUNev

    May 07, 2016 16:58

    I CANNOT SELECT ANYTHING!!! Please fix it unity. I just installed unity for the first time yesterday. I know how to use it, but every time I click on an object-- nothing happens. I hope you can see how this might hinder a user's ability to create something using this software.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.