Search Issue Tracker

Postponed means that the issue was either a feature request or something that requires major refactoring on our side. Since that makes the issue not actionable in the close future we choose to close it as Postponed and add it on our internal roadmaps and technical debt pages instead.

Postponed

Votes

40

Found in

5.2.0f2

Issue ID

722483

Regression

No

Scene View Navigation Delays

Scene/Game View

-

When moving around the scene view with WASD and mouse controls, the view will occasionally stop moving regardless of the current keyboard input.

Reproduction Steps:
1. Open any project or scene
2. In the Scene View hold down right mouse button to begin navigating
3. Without moving the mouse, alternate holding A and D to pan the camera
4. Occasionally the view will stop moving, usually when changing directions (see the attached GIF below)

Comments (27)

  1. A0bc9d46d40c3d31867c648749de38db?d=mm

    Fonserbc

    Mar 15, 2020 14:15

    I know this is an old thread, but tt still happens for me. (2017.4.37f1)

    As mentioned above, activating "Animated Materials" in the scene view fixes the problem (because it constantly forces the scene view to redraw).

    It seems to be something related to Keyboard Input in the Scene view.
    As mentioned above, the mouse-move input is registered immediately and triggers a scene view redraw, but the keyboard seems to not register the WASD buttons as being continuously pressed for around the first second after you press a key.
    Longer presses of keys work fine.

  2. 0f188ed3c5f56171f0806dcc1a5c8498?d=mm

    Vladerx

    Apr 17, 2019 11:36

    same here, toggling perspective from to ISO and back seems to temporary fix the issue

  3. 4dc5ad89a98b4fc336f41fd798d9406b?d=mm

    Bzuco

    Oct 26, 2018 11:03

    Change persp. view to iso and back to persp. is working for me, no lags, thanks :) .

  4. 743ada5ee9ddbe6e64124a452874f4a4?d=mm

    lucianomanso

    Aug 12, 2018 00:17

    In my case, I simple changed the perspective view to iso, navigated a little, than change to perspective again.
    I hope it help you guys!!

  5. Ea807b21d9e145d082cac463563fd402?d=mm

    pjbaron

    Jul 31, 2018 23:17

    Can we find out *why* this was postponed? It is a major problem.

    2018.1.6f1 moving the camera in the editor with WASDEQ will *frequently* pause then jump a huge distance leaving the camera a long way below the ground or outside of the scene.

    i7, 16GB RAM, GTX1060 on a very simple project with no Editor extensions running... this is not a 'cpu power' problem.

    I have dual monitors (1920x1080) and vs2017 open.

    I'll try the ridiculous suggestions here: https://forum.unity.com/threads/scene-view-navigation-with-wasd-very-laggy.380100/
    to see if any of them work for me but given the age of the early reports I am amazed there doesn't seem to be any action on this issue and no way of finding out if it is even being looked at.

  6. E904203def96149ff03dd678b2ce3282?d=mm

    Nieb

    Jul 06, 2018 03:11

    Any word on this being fixed?

    Experiencing it with Unity 2018.1.6f1.

  7. Ee1d20d531ca3ab11699e22411b2d551?d=mm

    lzinga

    Jun 10, 2018 03:08

    Still getting this, the workarounds don't work for me. Absolutely crazy unity thinks this is a back burner issue and that they think whatever work around is acceptable. Makes using the editor practically impossible.

  8. Dda6b24297b24b895d95c37a676921b4?d=mm

    TBUA

    May 28, 2018 07:43

    Guys the only work around i've found is playing a Youtube video in the bg. But honestly, I don't want to keep relying on this. Is there any other way I can get past this? This minor inconvenience is driving me nuts !

  9. 42629981bd338d906e1327eadbfe3c77?d=mm

    UltraPublicCoder

    Oct 10, 2017 07:42

    If you're using an MSI device this might fix your problem: http://answers.unity3d.com/questions/1153791/lag-in-scene-view-1.html

    Do you have Nahimic for MSI installed? That was the culprit in my case. Uninstall that shit and restart Unity, might work for you too. If it doesn't work, make sure there's not a service for it still running, also try rebooting after uninstalling it.

  10. D612ca675e58dd77898f4ecb8e36e7e6?d=mm

    EvilGremlin

    Aug 11, 2017 18:56

    Unbelievable that this is still not fixed. Postponed and voting is disabled. What a crock, Unity. At least give us the code so we can fix it if you don't want to.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.