Search Issue Tracker

Not Reproducible

Votes

4

Found in

2018.2.0b3

2018.2.15f1

2018.3.0a1

2019.1.0a1

Issue ID

1105494

Regression

Yes

Rect Transform tool handles sometimes become ungrabbable

uGUI

-

How to reproduce:
1. Open the user's attached project
2. In the Project window enter "New Scene"
3. In the Hierarchy window select Canvas->GameObject
4. In the Scene window try to grab Rect Tool handles and resize the Game Object

Expected result: Handles are clickable
Actual result: Handles do not react to being clicked on

Note: Double-clicking on "Canvas" or "GameObject" fixes the issue

Reproducible on: 2018.2.0b3, 2018.2.20f1, 2018.3.1f1, 2019.1.0a12
Not reproducible on: 2017.4.17f1

  1. Response avatar

    Resolution Note (fix version 2019.2):

    We are unable to reproduce this error from the dev side. After talking with QA who accepted it, resetting Unity's layout corrected the issue.

Comments (6)

  1. 91bea4320831b77e0941f652a988560c?d=mm

    hoodust

    Aug 29, 2019 16:54

    Can confirm this issue still exists in 2019.3.0a7. "Resolution" as noted worked for me: double-clicking a UI GameObject allowed me to use the Rect Tool again everywhere in the project. Not sure if related, but this issue occurred for me on a dual-monitor set up (one 4k one 1080) after dragging the game window around between screens.

  2. 2b298da0c2739428e4b04718d3516158?d=mm

    lsheron

    Jun 27, 2019 19:16

    Someone on my team figured out that by setting Layout to Default, it fixes this problem.
    We don't know why. But it's a consistent fix.

  3. 8d21544f958a7b3213692568e58b9916?d=mm

    ivan_tbl

    Apr 19, 2019 21:29

    Started happening from one day to another. Didn't change a thing in the whole project.
    Now I can't work.

  4. 6c386ad0319449a49e024bb44524c7f5?d=mm

    Alienmadness

    Feb 05, 2019 21:56

    i found that when probuilder is installed and you have accidently clicked to activate the vertex, edge or face selection tool. it disables the rect transform and other tools on the top bar.
    Changing probuilder back to Object Selection, fixed this for me.

  5. 911ce1c518958c5f794d6ad67e41ca4d?d=mm

    tk7

    Feb 05, 2019 19:51

    The Q/A team specifically noted what versions are effected and reproduced the issue in all of them. You can simply open the project and see that the entire rect tool no longer functions. Several users have experienced the same issue. Curious how this was marked not reproduceable?

  6. 911ce1c518958c5f794d6ad67e41ca4d?d=mm

    tk7

    Jan 02, 2019 14:24

    Issue started earlier this year. Sometimes goes away but then comes back. The entire Rect transform tool stops working, so you can't move object's locations or change their size using the mouse. Tried exporting and re-importing objects, removing and re-adding to scene, deleting and re-creating prefabs, no effect.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.