Search Issue Tracker

Fixed in 2020.1

Fixed in 2019.3

Votes

60

Found in

2019.2.0a7

2019.2.0f1

2019.3.0a1

Issue ID

1174475

Regression

Yes

Parts of Cloth Mesh disappear when entering Play mode

Physics

-

To reproduce:
1. Open attached project ("case_1174475-ClothIssue.zip")
2. Open Assets -> Scenes -> "SampleScene"
3. Press Play and observe GameObject with Cloth in GameView

Expected result: Cloth Mesh is fully visible
Actual result: Parts of Cloth Mesh disappear

Reproduced in: 2019.2.0a7, 2019.2.1f1, 2019.3.0a12
Not reproducible in: 2019.1.14f1, 2019.2.0a6
Could not test in: 2017.4.31f1, 2018.4.6f1 (project kept breaking)

  1. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in 2020.1.0a19

Comments (11)

  1. Ea8897dae08ed0e6f99b1709117c819e?d=mm

    CosmosBear

    Dec 17, 2019 14:08

    So it's been 5 months... how about fixing it before Christmas?

  2. 1184606c6a0eadafe022fac44151535e?d=mm

    Qleenie

    Dec 11, 2019 06:55

    Disable optimize mesh only fixes some issues, not the one described here. at least not on more complex meshes.

  3. 2c383450a9d6119fc0493e4b93a553e7?d=mm

    lejean

    Dec 08, 2019 17:30

    Disable vertex order in your object's "Optimize Mesh" dropdown seem to make it behave normally.

  4. Ee1ae2e0411621c9709a56bbf29fcfde?d=mm

    vagele86

    Dec 03, 2019 08:28

    Please fix it!!!

  5. 1184606c6a0eadafe022fac44151535e?d=mm

    Qleenie

    Dec 02, 2019 15:40

    I tried also in Unity 2019.3.0f1. For me it's still not working correctly, albeit it seems a bit better than before, the distortion is more limited, but still HUGE frame drop, and still it looks pretty unstable simulation, very different from 2019.01

  6. C0e1f91ace933c60bc8ea6b22c27f81b?d=mm

    RakNet

    Nov 28, 2019 18:30

    Cloth is working for me in Unity 2019.3.0f1. I'm the one that originally reported the issue in https://fogbugz.unity3d.com/default.asp?1174475_vd4vh26sanqp9avj

  7. 89648c1019679041b7fb111cbbcb36e7?d=mm

    SomeGuy22

    Oct 14, 2019 18:32

    In my findings it seems as though this issue is related to what happens when you enter playmode while a cloth is in a "bugged" state, i.e. it stretches/distorts randomly in the Editor. Discussion on the Unity forums have yielded a potential workaround for getting cloth out of this bugged state. In my test cases, disabling mesh optimization (setting from "All" to "None" in the import window) allowed cloth to behave normally. This makes it seem like recent changes to mesh optimization could be related and is worth looking at for Unity devs to track down the cause. More info is given on this thread:

    https://forum.unity.com/threads/major-cloth-issues-in-v2019-2-0f1.730385/

  8. 4a0e4475db997596a6bd8a534a3c883e?d=mm

    AndrewRH

    Oct 03, 2019 14:27

    Please fix! It's currently not possible to upgrade a project from Unity 2018 to 2019 with cloth in it...

  9. 5c62cd77d526575d6149cc206a7d4578?d=mm

    SupraLP

    Sep 22, 2019 18:32

    still present in 2019.3.0b3

  10. 192fbeb6185840da2cfcbf62c15c9ecd?d=mm

    NathanRH

    Sep 18, 2019 17:39

    Vote

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.