Search Issue Tracker

Fixed in 2021.1.X

Votes

0

Found in

2020.1.15f1

2021.1.0a10

Issue ID

1299159

Regression

Yes

[Packman] shows error “Unable to get purchase details because you may not have purchased this package” when package is free

Packman

-

How to reproduce:

1. Create a new project
2. Open package manager
3. Open Unity Asset Store in Browser
4. Find free Asset. eg. https://assetstore.unity.com/packages/2d/environments/free-platform-game-assets-85838
5. Press "Open in Unity"
6. It opens in Package Manager

Result: User sees error on top "An error occurred: Unable to get purchase details because you may not have purchased this package."
Expected result: when package is free, this error shouldn't appear

Reproducible: 2021.1.0a10.1694, 2021.1.0a2.727, 2020.2.0b13.3614, 2020.2.0b8.3329, 2020.1.15f1.4895,
Not reproducible: 2019.4.15f1

Comments (5)

  1. 62b7972e315e912d279e782d6ffd2b91?d=mm

    OPLarge

    Jul 01, 2021 15:24

    I know how to fix this (at least it worked on 2021.1.13f1):

    Unlog from your Unity account on the editor, and then log back in. I got the same problem, and tried this

  2. Af2919166984696074512500cb312926?d=mm

    VeniVidiVicky

    May 04, 2021 13:06

    The same happens with 2021.1.5f1following the unity tutorial trying to import the Yughues Free Ground Materials

  3. 2766dea7940c5285fff4e9a4af64f412?d=mm

    burakkurkcu

    Apr 20, 2021 07:39

    Using 2020.3.4f1 LTS and it's not fixed!

  4. 05652696f96af39e1e4bccb779407328?d=mm

    yemchik

    Apr 16, 2021 17:25

    This issue is not fixed

  5. 05652696f96af39e1e4bccb779407328?d=mm

    yemchik

    Apr 16, 2021 17:24

    I am using unity 2021.1.2f1
    I bought an asset from the unity asset store for $10. I tried to open it in unity and it is giving me this same error message. I am unable to download the asset. Help!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.