Search Issue Tracker


Fixed in 2019.3.X



Found in



Issue ID




[OSX] Unity fails to ask camera permission and crashes on privacy violation



How to reproduce:
1. Open the "" project
2. Open the "SampleScene" scene
3. Enter Play Mode

Actual result: Unity crashes.

Reproducible with: 2020.1.0a15, 2019.3.0f2, 2019.2.15f1, 2019.2.0a1, 2019.1.14f1, 2019.1.0a10.
Regression introduced in: 2019.1.0a10.
Not reproducible with: 2019.1.0a9, 2018.4.14f1, 2017.4.35f1.

- same crash happens when using Vuforia.
- Reproducible on both OSX Standalone and Editor

  1. Resolution Note:

    Fixed in Hub 2.3.1

Comments (25)

  1. borwicka

    Apr 03, 2020 13:44

    @launzone - I tried your method, although I get this response in Terminal at Step #4: "table access has 7 columns but 12 values were supplied". Do you have any suggestions for how to remedy this?! Running OS 10.11.6. Thanks!

  2. Maidenman

    Apr 03, 2020 09:16

    Big THANK YOU @launzone - your solution works for me perfectly!

  3. dskillsaw

    Apr 02, 2020 18:09

    I followed LAUNZONE's fix from the march 30 comment. Fixed it for me!\

    Catalina's permission issues are absolutely nightmarish :(

    Please unity prioritize this issue (even though I'm sure it's Apple's fault in this case).

  4. dskillsaw

    Apr 01, 2020 18:44

    (ignore my comment below. Didn't realize your most recent post was the workaround to try)

  5. dskillsaw

    Apr 01, 2020 18:13

    @LAUWISMEMAR, what was your workaround?

  6. launzone

    Mar 30, 2020 04:10

    Hey everyone, I know that this is not ideal and unity or apple should come up with a better solution eventually but here is what works for me and is pretty sure to work for everyone that can't add microphone or camera permission to unity hub. It is kind of weird and you have to disable SIP (system integrity protection) for a couple of minutes to do it, so maybe read up on that first if you are worried (I was not).

    1) Disable SIP: Go into recovery mode (hold CMD+R when you restart your Mac) Don't be afraid, we are not doing anything crazy.

    2) After that open Terminal (it should be accessible from one of the Menus at the Top) Type in "csrutil disable" and hit enter. Then reboot your Mac normally.

    3) Open Terminal and type in: "sqlite3 ~/Library/Application\ Support/" and hit enter

    4) For microphone access, type in: "INSERT INTO access VALUES('kTCCServiceMicrophone','com.unity3d.unityhub',0,1,1,NULL,NULL,NULL,'UNUSED',NULL,0,1541440109);" and hit enter

    For camera, type in: "INSERT INTO access VALUES('kTCCServiceCamera','com.unity3d.unityhub',0,1,1,NULL,NULL,NULL,'UNUSED',NULL,0,1541440109);" and hit enter

    6) check in your SystemPreferences/Security&Privacy > unity hub should now show up in both mic and cam

    7) reboot in recovery mode again (CMD+R), open terminal again, type in: "csrutil enable" and hit enter, to enable SIP again

    8) reboot normally and enjoy!

    That's it! I hope it works for you. Don't forget the step 7, I think it is important for Security.

  7. Idealisers

    Mar 25, 2020 13:55

    I thought I fixed this issue on 2019.3.6f1 but after Catalina update (10.15.4) I can't get it to work again. So it seems the mac os update messed up my camera permissions again for unity.
    Permissions are not asked when running a project in 2019.3.6f1 and my app that uses the camera crashes inside the editor in playmode.
    I used tccutil reset Camera to get rid of all camera permissions, uninstalled all unity versions, uninstalled unity hub, reinstalled unity hub and unity, but all to no avail.
    I guess I need to move to a windows unity machine.

  8. marcin-walus

    Mar 25, 2020 08:02

    I spot that Unity 2019.3.6 has proper key in Info.plist.... for camera, so it should work

    But what about microphone? Same applies to microphone permissions.
    Please fix it also for microphone.

    Thank you

  9. marcin-walus

    Mar 21, 2020 14:15

  10. marcin-walus

    Mar 21, 2020 13:50

    I have same issue on Unity 2019.2.17f1 on freshly installed macOS Catalina 10.15.3
    Solution with removing UnityHub and using Unity app directly works.

    I can't believe that so basic OS functionality is not handled correctly by Unity - this is not new macOS feature which came yesterday. I think this issue is not related to Unity version it should be fixed in UnityHub since this process is starting Unity app instances.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.