Search Issue Tracker

Active

Votes

9

Found in

5.2.0f3

Issue ID

727114

Regression

No

[OSX] Shader import in an external exFAT drive crashes Unity

Asset Importers

-

How to reproduce:

1. Open a new project in an external drive formatted as exFAT
2. Create a new shader
- Unity throws an error upon validating the name of the shader:
- attempt to write a readonly database
- UnityEditor.DockArea:OnGUI()
- The only option at this point is to Quit Unity
- This appears to only happen with shaders
- Re-opening the same project sometimes causes the same error to be thrown during Asset Import
- Attempting to delete the shaders after opening the project also causes an error

Comments (5)

  1. 9cfedd29c0773acdb37938593772d305?d=mm

    threesds

    Nov 27, 2018 16:57

    On OSX ExFat partition the following worked for me. $SHADER is the shader file that unity reports in the error message.

    cat $SHADER
    (copy shader contents on the terminal)
    rm $SHADER
    vim $SHADER
    (post shader contents into vi and save)

    Creating the file as the user that will run Unity seems to work around the problem. You may have to do this multiple times, opening the project or doing import until each item is discovered.

  2. A80be4f5e41fa16d04c6fb377476a0d6?d=mm

    XRCT

    Mar 12, 2018 08:05

    This still happens in 2018.1.0b10, my exFAT Samsung T5 gets "attempt to write a readonly database" on asset import for my ~600mb project. I had to move everything to my internal APFS drive.

  3. Bf580fc81d1aedaf8d8960afc7072845?d=mm

    tuanpham_exoty

    Sep 28, 2017 15:22

    please fix it, i have this iusse too

  4. 55711e05326ed00f5073296433abeca4?d=mm

    Vadammt

    Jul 17, 2017 00:12

    I have the same Problem.
    After importing Textmesh Pro into my project Unity keeps crashing while importing the Shaders.
    I tried running as ``sudo`` but this doesn't help.

    I'm Using Unity 2017.1.0f3 Personal on macOS Sierra (10.12.5 (16F73)) and the Unity Project I try to open is located on an exFAT formated HDD.
    The project directory is (yes I'm German):
    ```
    /Volumes/Daten/Medien/Programmieren/Unity/BW_Naturschutz_Memory/Assets/TextMesh Pro/Resources/Shaders
    ```

  5. E6a7b77eca37855c736c62d938515b5a?d=mm

    huulong

    Apr 24, 2017 23:46

    In my case, happened after cloning a Git project repo to an external SSD, exFAT too. Since the Library is ignored, Unity needs to reimport everything, and the crash occurred just when importing a shader.

    My Editor log:

    [Updating a bunch of shaders before this one]
    Updating Assets/Standard Assets/Effects/ImageEffects/Shaders/_Antialiasing/DLAA.shader - GUID: 017ca72b9e8a749058d13ebd527e98fa...
    attempt to write a readonly database

    (Filename: /Users/builduser/buildslave/unity/build/External/sqlite/SQLite.cpp Line: 345)

    The database in question is probably Library/ShaderCache.db

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.