Search Issue Tracker

Fixed in 2020.2

Fixed in 2019.3, 2020.1

Votes

89

Found in

2019.3.0f6

2020.1.0a20

Issue ID

1215431

Regression

Yes

NullReferenceException is thrown when inspecting a .FBX file with multiple clips and opening Animation tab

Asset Importers

-

How to reproduce:
1. Open the attached 'project-1215431.zip' project
2. In the Project window select 'MultiClipSingleFile'
3. Observe the Console window
4. In the Inspector select 'Animation' tab
5. Observe the Console window

Expected result: NullReferenceExceptions are spammed in the Console window, the asset is broken
Actual result: No exceptions are thrown in the Console window, the asset is not broken

Reproducible with: 2019.3.0f6, 2020.1.0a20, 2020.1.0a21
Not reproducible with: 2017.4.36f1, 2018.4.16f1, 2019.2.20f1, 2019.3.0f5, 2020.1.0a1, 2020.1.0a19

Thrown exceptions:
1) NullReferenceException: Object reference not set to an instance of an object
UnityEditor.ModelImporterClipEditor.FindNextAvailableName (System.String baseName) (at <866e5e4337c74147a9a0249666f72660>:0)

2) NullReferenceException: Object reference not set to an instance of an object
UnityEditor.ModelImporterClipEditor.AnimationClipGUI () (at <866e5e4337c74147a9a0249666f72660>:0)
UnityEditor.ModelImporterClipEditor.OnInspectorGUI () (at <866e5e4337c74147a9a0249666f72660>:0)

  1. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0a1

  2. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in 2020.1.0a26

  3. Response avatar

    Resolution Note (fix version 2019.3):

    Fixed in 2019.3.4f1

Comments (39)

  1. 52e43349d432df73882657fcae43aa05?d=mm

    KliveOne

    Feb 03, 2020 10:00

    Im getting the same issue. The only change is that I updated my projects Editor from 2019.3.0b11 to 2019.3.0f6. Been doing this the whole project on the older unity. Just today after updating I am getting this error and cannot use/import my meshes with animation clips.

  2. C5062031f24d448cf25924e738d211fa?d=mm

    SixTimesNothing

    Feb 02, 2020 10:44

    The workaround of importing via an earlier version of Unity didn't work for me – same error occurs when bringing the imported asset back into the 2019.3.x project. The best way around this is to split the multi-animation clip .FBX file into multiple single animation clip .FBX files. Where there is only one clip, I didn't see the problem and the animations imported fine for me.

    Was ok for me as I had a low number of animations – can imagine that would be annoying with complex characters, etc. until the Unity team can fix this one.

  3. 59342fef6207de40640be85647522900?d=mm

    Thibaa

    Feb 02, 2020 01:55

    for anyone who got those kind of trouble just import your fbx in an older Unity version (2019.2.x worked for me) and export it as a package, then just bring it back in 2019.3 and it should go well (at least worked for me

  4. Bf15e06e613baf4c1313c7b268a51050?d=mm

    Zhemo17

    Feb 01, 2020 23:11

    Same :')

  5. Af06b5e7e937747db5f1af8f1b4bf5d1?d=mm

    ade72

    Feb 01, 2020 19:15

    Same here.

  6. 6c1d6881024337833e99b44012fc3ca3?d=mm

    matty9090

    Feb 01, 2020 10:59

    My workaround for this issue is to open up a previously imported fbx meta from an older version of Unity and paste in the animationClips section, changing the settings you need (in my case just setting loopTime to 1 to loop animations).

  7. 268c94b6ccac4ab5ecae1f8e7dec1566?d=mm

    blai30

    Feb 01, 2020 03:50

    Anyone know a fix for this?

  8. 54b0da3336ae4ae3d6167f82c00b6ccb?d=mm

    Oxeren

    Jan 31, 2020 18:31

    Getting the same issue, can't work on animated models because of that.

  9. 67568bd393bbea08d78a899503e0cf7f?d=mm

    z4g0

    Jan 31, 2020 15:37

    Just noticed the same issue after the update to 2019.3.0f6.
    The previously imported .fbx still works ( "Animations" tab works and doesn't flood errors ), but if I import a new fbx ( or reimport a fbx that worked well on 2019.3.0f1 ) and I click on "Animations" tab, it starts to flood the reported error.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.