Search Issue Tracker

Fixed in 5.3.6

Votes

49

Found in

5.3.1p2

Issue ID

761548

Regression

Yes

[MovieTexture] FMOD error when trying to play video using WWW class

Video

-

Repro steps:
1) Open the project and only scene in it
2) Play - notice that the movie texture and the sound works correctly
3) Notice the errors in the Console: "Error: Cannot create FMOD::Sound instance for resource (null), (An invalid parameter was passed to this function. ) "

Reproduced in: 5.4.0b2; 5.3.1p3; 5.3.0f4
Not reproduced in: 5.2.3p3

Comments (63)

  1. 8b99659910f7b89c43906ac2378bb4e9?d=mm

    MvanDoorn

    Jul 28, 2016 11:48

    Definitely not fixed yet unfortunately, can't ship until fixed, last bug remaining

  2. 586a47b1ad8118b77f1ae377ffa7fbd9?d=mm

    tolstenko

    Jul 27, 2016 13:13

    Still not fixed on 5.4.0f1! Video encoded without audio and pixel format yuv420p using this command line:
    ./ffmpeg -i rainbow%03d.png -codec:v libtheora -qscale:v 9 -pix_fmt yuv420p outputhsv.ogv

  3. E9107179ef5b424002666a2c6eca058f?d=mm

    Alex_Alex

    Jul 27, 2016 08:47

    Still not fixed in Unity 5.3.6f1

  4. Fa765d8c24eec7639c974c87e2955d3b?d=mm

    gaint_lindsay

    Jul 25, 2016 23:53

    I am still receiving this exact same error in Unity 5.3.6f1 when loading a file:/// url!
    Tried all of the suggestions on this page and related forum posts (waiting for isDone and is ready etc).

    Works in 5.3.6f1 when using a remote http:// uri, but NOT when using a file:/// uri.

    Nothing wrong with my file accessibility and format (its an MP4, recorded straight from the PS4)

  5. 1cb1fd93eafe8024140e17833e178a69?d=mm

    Rajesh-Dhopate

    Jul 25, 2016 06:31

    Not fixed in Unity 5.3.6f1

  6. 0edce28fd842316c88f0e9c00cc96b8c?d=mm

    Afro_Games

    Jul 21, 2016 19:33

    Still broken in Unity 5.3.6

  7. 5b81e69bf02417d8211f9dec4422d36e?d=mm

    ludo6577

    Jun 30, 2016 10:52

    They know about this issue, you can follow the resolution here:
    https://fogbugz.unity3d.com/default.asp?807622_8194nt9k70h456fc

  8. 115073ea61296f7472b6d7019348df21?d=mm

    Tilonsoft

    Jun 28, 2016 17:19

    This isn't fixed!

  9. 4acd1b44b07202903b2e00c935dabeb2?d=mm

    DantaliaN

    Jun 24, 2016 02:45

    not fixed in 5.3.5f1
    Please, fix it

  10. 5b81e69bf02417d8211f9dec4422d36e?d=mm

    ludo6577

    Jun 20, 2016 11:55

    Not fixed in 5.4.0b18 and 5.3.4f1
    I tried with ogg files encoded with libtheora as explained in the documentation.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.