Search Issue Tracker

Fixed in 2018.1.X

Not Reproducible in 5.6.X

Fixed in 2017.3.X



Found in


Issue ID




m_CurrentEntriesPtr != NULL && m_IsGettingEntries error thrown when double clicking on a specific warning



To reproduce:

1. Open the project, attached by user (
2. Enter and exit Play mode. Warning "Invalid texture used for cursor - check importer settings" should be shown
3. Double click on warning
4. Observe console

Expected: double clicking on warning does not throw any errors
Actual: "Assertion failed: Assertion failed on expression: 'm_CurrentEntriesPtr != NULL && m_IsGettingEntries' error is thrown after double clicking on specific warning

Reproduced in 5.5.3.p2, 5.6.1f1, 2017.1.0b5

Regression introduced by this changeset: 63394166f856

Comments (19)

  1. Tim_Timoff

    Mar 26, 2018 08:03

    I am also getting it with Unity 2017.3.1

  2. creativewax

    Mar 08, 2018 12:34

    Happens randomly for me, happen again today on 2017.3 when importing a project, without doing anything the error keeps getting logged to the console

  3. fashrista

    Mar 03, 2018 15:01

    yeh I have the same isue and was directed to this thread by unity bug report staf ie this is a known error, but me being here does not exactly solve it, does it? ;D

    For me the issue started after inporting my project into new beta version. It goes away if I slear the console. Everything works for me I gues it is not aserious problem?

  4. Kill22pro

    Feb 27, 2018 08:37

    Same error, but maybe from a different cause.
    Unity 2017.3.1p1

    Assertion failed: Assertion failed on expression: 'm_CurrentEntriesPtr != NULL && m_IsGettingEntries'
    System.Runtime.CompulerServices.ExecutionScope:lambda_method(ExecutionScope, Object, Object[])
    FlyingWormConsole3.FastMethodInfo:Invoke(Object, Object[])
    FlyingWormConsole3.NativeLogs:RefreshEntries(Boolean, Boolean)

  5. hippogames

    Feb 22, 2018 12:06

    The same error when building to Android. 2017.3.1p1

  6. toncho11

    Feb 20, 2018 08:33

    Got the same error. Updated to 2017.3 from 2017.2. Left the game for a long time running.

  7. drdysdy

    Jan 24, 2018 06:42

    Getting the same issue after updating my Unity version. I'm not sure what version I was on, but it wasn't very old. The new version is 2017.3.0f3

  8. Willkuerlich

    Jan 03, 2018 17:57

    Me 2, got it after double clicking error in console. The error was caused on unity startup loading of the scene and there was a null-reference exception in a OnDisable function called.

  9. Matheus-Crivellari

    Jun 04, 2017 17:58

    I had the same problem but when double clicking an error

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.