Search Issue Tracker

Fixed in 2019.1.X

Fixed in 2017.4.X, 2018.1.X, 2019.2.X



Found in



Issue ID




[Linux] keystrokes recorded twice



-e: when typing into input fields each letter is recorded twice for each key stroke
--works well in 2017.1.2p4., 2017.2.1p1, stops working in 2017.3.0f3

--open attached project
--build linux standalone
--run build
--enter something into either input field
--NOTICE the letters being written twice

  1. Resolution Note (fix version 2019.1):

    Fixed keystrokes from being recorded twice while using text fields in play mode in the editor.

Comments (2244)

  1. gserrg

    Jun 07, 2018 19:07

    Same issue causing me problems.
    "engine_ver": "2018.1.0f2"
    Linux system is Ubuntu 16.04 LTS x64

    !!! However, when using the source "Russian" Russian letters are not duplicated

  2. Alloc

    May 24, 2018 17:58

    What about a backport of the fix to 2017.4 (after all it's supposed to be a LTS release and I'd count this as a major bug to be fixed) and 2018.1 as 2018.2 will probably stay in beta for a while?

  3. LawrenceBarbarian

    May 16, 2018 19:46

    Same here. I'm using Mac to build Linux64 headless server. The GUI text boxes always register a single keyboard stroke as a double - same with Pasting (ctrl + v) - I get two (2) copies of the string in the text box.

    It's not the keyboard repeat settings (i've tried that as well) and it even does in from within a Virtual Box VM (Ubuntu 16.04) with Unity 2017.4.1f1 version running on Mac or Windows > building for Linux.

    Hope this is something that Unity can resolve as even delete key deletes 2 chars at a time. - very frustrating bug to say the least.


  4. cobolfoo

    May 10, 2018 23:11

    Same here on the latest 2018 beta, Ubuntu 18.04.

    Seems to not affecting Ubuntu 16.04!

  5. mmozeiko

    May 07, 2018 23:36

    I also see this issue still happening with 2018.1.0f2 version on Ubuntu.

  6. tudor-ciomartan

    May 02, 2018 22:09

    Still occurring with Unity 2018.1.0f2

  7. x4000

    May 02, 2018 19:55

    A fix for this in 2017.4 would be extremely welcome.

  8. singhblom

    Apr 16, 2018 13:46

    I just ran into this issue on Unity 2018.1.0b13 (64bit) on Ubuntu 17.10, so I'm not sure if it's been correctly resolved.

  9. zibas

    Mar 24, 2018 18:37

    Not fixed in 2017.4

  10. hobbyte

    Mar 19, 2018 10:26

    I'm not sure if I'm late to the party, but I just wanted to add my two cents:

    Characters aren't actually typed twice - the "basic" key is typed before the actual input, so for example, "Hi@Unity" becomes "hHii2@uUnniittyy".

    If the issue has been fixed, then I expect the dev who fixed it already noticed this, but I figured I should mention it anyway.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.