Search Issue Tracker

Fixed in 5.2.1

Votes

8

Found in

5.1.2f1

Issue ID

718387

Regression

Yes

[iOS] Some unicode characters not displayed

iOS

-

There’s no full workaround for the issue. I’ve found that after adding the following fonts to the font fallback list in “Filesystem.mm” in the trampoline, there are _almost_ no regressions compared to iOS8.

“Helvetica”, "Hiragino Mincho ProN”, "PingFang HK” and "Noto Sans Yi”

The remaining regressions can be divided into two parts:

- Emoji characters. It’s not possible to support them because Apple now uses a different font format for font that contains these characters. We don’t support the new font format. Full fix is not expected until 5.3 at the earliest.

- Approximately 1% of random Chinese characters. I did not yet investigate this issue yet.

To Reproduce:

1. Open and deploy the project from 'fonttest.zip' (original project doesen't work on 5.2+ due to ngui stuff).
2. Observe that some Unicode characters in the top left corner are not working on iOS9 (some also on iOS 8):

Comments (9)

  1. 8aef82b9ffd0ea48898707589039cec1?d=mm

    tyoc213

    Dec 16, 2015 16:35

    It will be available for 4.x releases?

  2. 0510a86b8d79fc680529559327231712?d=mm

    furic

    Oct 08, 2015 00:19

    Having this issue is 4.6.6, please port this to 4.6 asap, thank you very much.

  3. 02f9d1cb2f157adef21c6a8148f10d82?d=mm

    Toxast

    Oct 06, 2015 11:25

    Fix still not ported for 4.6?

  4. 02f9d1cb2f157adef21c6a8148f10d82?d=mm

    Toxast

    Oct 06, 2015 11:24

    Fix still not ported for 4.8?

  5. 07ded4217b536b6f7c465d1dca8271ec?d=mm

    Mr Asset

    Sep 28, 2015 02:34

    Are those all the fallback fonts you specify? It doesn't seem to include, e.g., Arabic, and I doubt Simplified Chinese characters are properly covered as part of the PingFang HK font.

    Overall, I think Unity should strive to track the same fallback fonts as the base OS uses. Having to worry about missing glyphs should really be a thing of the past.

  6. 868d601a41ee54e416076bcfcf6d928f?d=mm

    mohit.parihar

    Sep 25, 2015 04:45

    Hi,

    I have the same problem with a current project that I’m doing with NGUI.
    Is there anybody who was able to fix this issue?

  7. Cf56ef8b3c6f13bfe37d0d8810dd5204?d=mm

    mmunson

    Sep 10, 2015 23:17

    broken chinese character:

    http://www.fileformat.info/info/unicode/char/503c/index.htm

    indeed this is not present in any of the PingFang fonts, yet the iOS device can display it so there must be some system font that does contain this glyph...

  8. 3fa9ac1c06dcffb9c2869cbacd1aeaf7?d=mm

    Permantier

    Sep 04, 2015 06:05

    Hi,

    Same problem here.

    I tried with Unity 5.0.2 and 5.1.3. On 5.0.2, all the characters were broken and about 10% were broken on 5.1.3.

    Any fix?

  9. D0df8913f8cd4f44b1a429f3aa4dc06a?d=mm

    GameSpring

    Aug 24, 2015 01:09

    I have the same problem with a current project that I’m doing with NGUI. I also made an empty sample project with uGUI, but it has the same problem.

    Is there anybody who was able to fix this issue?

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.