Search Issue Tracker

Duplicate

Votes

12

Found in

5.4.0b18

Issue ID

813482

Regression

No

[iOS] Crash in DrawBuffers() before splash screen with Metal on iOS 10

iOS

-

Steps to reproduce:
1) Open the last attached project (OC link).
2) Build for iOS with Metal as Graphics API.
3) Run on a device

The app crashes in 'DrawBuffers()' (GetPrimitiveCount at GfxDeviceMetal.mm:618). This issue doesn't appear with GLES2/3.

Comments (10)

  1. 1c2a37d6b044b0b1398802155d7c0d38?d=mm

    GHSmediaSrl

    Dec 20, 2016 16:35

    I've got this same problem too with a google VR v1.0

    My versions :
    OS:iphone 6
    XCode 8.2
    Unity 5.3.5f1
    iOS 10.2
    Google VR 1.0

  2. 226e553151489fc94cd95e937c9b5088?d=mm

    steampunkdigital

    Nov 03, 2016 20:14

    Also got this on iPhone 6s, iOS 10.1 with Uniy 5.4.2f2. Xcode 8.1

  3. 48b58531659b568938344969a0c5a5df?d=mm

    leilei0910

    Oct 31, 2016 05:13

    I've got this same problem too with a google VR v1.0

    My versions :
    OS:iphone 6s
    XCode 8.1
    Unity 5.4.0f3
    iOS 10.1
    Google VR 1.0

  4. 52cb9d0d22d063133cc78ec4b408a459?d=mm

    CaspianArts

    Oct 22, 2016 05:09

    Unity 5.4.1f1
    XCode 8
    iOS 10

  5. F830ca8693e71e343095f1b5aaa2e8b0?d=mm

    Ian3934

    Oct 20, 2016 15:10

    I'm having the same problem with a Google VR app running on an iPhone 7.

    Unity 5.4.2f1
    Xcode 8.0
    Google VR 1.0.1
    iOS 10.0.3

  6. 10dc566a31bb11e9672d7e7e1ff3fe14?d=mm

    rrsimon

    Oct 19, 2016 14:23

    Also got this on iPhone 7 iOS 10.0.3 with Uniy 5.4.2f1

  7. Ac2b2ceaa31183dfec99d62e76efc0b8?d=mm

    DoctorMobius

    Oct 11, 2016 21:49

    My Google VR 1.0 project does this too.

    Xcode 8.0
    Unity 5.4.1f1
    iOS 10 (app using Metal)

  8. Efd289d6f79416e3437826a008940872?d=mm

    esantacruz

    Oct 08, 2016 21:12

    I've got this same problem too with a google VR v1.0 My versions :

    OS Sierra
    XCode 8.0
    Unity 5.4.1f1
    iOS 10
    Google VR 1.0

  9. 81098f4d1dd6a976a7ba08f95e978c3b?d=mm

    AlexS-Digiworks

    Sep 22, 2016 14:38

    I've got this same problem too with a very simple videosphere app. My versions :

    XCode 8.0
    Unity 5.4.1f1
    iOS 10

    Works fine with an iOS 9 device

  10. 08f2ebb43577ea9665593c9a9e630676?d=mm

    Pashpash

    Sep 17, 2016 00:07

    I'm experiencing the same issue using 8.0 (8A218a), Unity 5.4.1p1, and iOS 10.0.1. I switched to a different phone running iOS 9.3 and the project worked with no changes.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.