Search Issue Tracker

Fixed in 5.3.8

Votes

90

Found in

5.4.1f1

Issue ID

832578

Regression

Yes

[iOS] Audio with 'Streaming' Load Type does not play on some devices running iOS 10

iOS

-

If an Audio Clip has its Load Type set to 'Streaming' it does not play on some older devices running iOS 10.

Steps to reproduce:
1) Open the attached project (streamingTest_832578).
2) Build for iOS.
3) Run on a device via Xcode.
4) When the app launches, press any of the UI buttons on the screen.

A sound should be played, however it does not. An error message is displayed in the Xcode's console:
Error: Cannot create FMOD::Sound instance for resource resources.resource, (An error occured that wasn't supposed to. Contact support. )

It does not occur if the Load Type is set to 'Decompress On Load' or 'Compressed In Memory'. This only happens with iOS 10.
It seems that only older devices (like iPhone 5, iPad 4) are affected.

Reproduced on:
5.5.0b4, 5.4.1p1, 5.3.6p5, 5.3.5p6

Did not reproduce:
5.2.4f1

I was able to reproduce it on iPhone 5, running iOS 10.0.1
Devices running iOS 10 that did not reproduce:
iPhone 6, iPhone 6 Plus, iPad Mini 2, iPhone SE.
Other users reported that this is also reproducible on iPad 4th gen and iPhone 5C.

Comments (47)

  1. 5c58a8c8cfdba8d8212c2eb81e56691c?d=mm

    andymads

    Oct 04, 2016 14:58

    Using 5.3.6 with an iPad Mini 2 I found that it happens when using Mono scripting backend but not with IL2CPP.

  2. 1a1bb11515932b7dde535373a4c38443?d=mm

    Chanyutx10

    Sep 29, 2016 11:11

    Confirm the problem exists in Unity5.4.1f1.
    I have tested in these devices
    - iPhone6 running iOS version 10.0.2 (14A456)
    - iPad Air running iOS version 9.3.5 (13G36)

  3. Dca30f727f61adc33a560a282390e6da?d=mm

    Alexander-Seeck

    Sep 29, 2016 07:57

    I can confirm that the problem exists in Unity5_5_0p5.
    I even tried overriding every streaming setting for iOS to "DecompressOnLoad" to no avail.
    Moving back to 5.3.5p5 actually really fixed it for us.

  4. 08b9a9a9c1d56ffc2c6d0d170ac47c19?d=mm

    justdizzy

    Sep 26, 2016 20:13

    I have verified using an iPad 4 running iOS 10.0.2:
    Issue exists:
    5.3.6p6

    Issue does NOT exist:
    5.3.5f1
    5.3.5p5

    Looking at the release notes, there were some big changes in 5.3.5p6 in regards to streaming audio, which might be the culprit. Based on dates, these changes are probably in all versions of Unity greater than 5.3.5.

  5. Dba28d98f8dcc49449d25d5352cbcb6d?d=mm

    FundaySoftware

    Sep 26, 2016 13:18

    Upvoted.

    Any workaround here would be lovely, as it is stopping us from releasing an update to Spellbinders on iOS.

  6. D93498d39c3bd59f964e71344bb5ad42?d=mm

    tomerrei

    Sep 25, 2016 11:31

    Any workaround known for this will be blessed...

  7. 16f6d049bcb9b2d7509030c3b3047b99?d=mm

    Chris-Kaynor

    Sep 21, 2016 16:07

    It may be useful to know that the issue does not seem to occur on 5.3.5p4.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.