Search Issue Tracker

Fixed in 5.3.8

Votes

90

Found in

5.4.1f1

Issue ID

832578

Regression

Yes

[iOS] Audio with 'Streaming' Load Type does not play on some devices running iOS 10

iOS

-

If an Audio Clip has its Load Type set to 'Streaming' it does not play on some older devices running iOS 10.

Steps to reproduce:
1) Open the attached project (streamingTest_832578).
2) Build for iOS.
3) Run on a device via Xcode.
4) When the app launches, press any of the UI buttons on the screen.

A sound should be played, however it does not. An error message is displayed in the Xcode's console:
Error: Cannot create FMOD::Sound instance for resource resources.resource, (An error occured that wasn't supposed to. Contact support. )

It does not occur if the Load Type is set to 'Decompress On Load' or 'Compressed In Memory'. This only happens with iOS 10.
It seems that only older devices (like iPhone 5, iPad 4) are affected.

Reproduced on:
5.5.0b4, 5.4.1p1, 5.3.6p5, 5.3.5p6

Did not reproduce:
5.2.4f1

I was able to reproduce it on iPhone 5, running iOS 10.0.1
Devices running iOS 10 that did not reproduce:
iPhone 6, iPhone 6 Plus, iPad Mini 2, iPhone SE.
Other users reported that this is also reproducible on iPad 4th gen and iPhone 5C.

Comments (47)

  1. D93498d39c3bd59f964e71344bb5ad42?d=mm

    tomerrei

    Nov 20, 2016 08:03

    What do they mean by "Status: Fixed in Unity 5.3.9"...
    Is there Unity version 5.3.9 somewhere...

  2. 84b0b5f4655af4d98c43315ec154daf2?d=mm

    matthewdominey

    Nov 18, 2016 15:23

    Disappointing that this was still not fixed in the new release. This is causing delays in releasing for my company as well.

  3. Dcd65d5aab1decb0e293ab8eb099610d?d=mm

    theredace

    Nov 18, 2016 14:50

    We continue to wait for this bug to be fixed before we can ship our game.

  4. 4ccbe3ef7f22a4d3e6dc29bea0467102?d=mm

    Catsoft-Studios526

    Nov 10, 2016 07:57

    Yesterday a new Unity patch was released but this bug seems to not be fixed. Isn't this a critical issue? We can't ship our game if the background music throws an exception and doesn't play (and changing loading type to compressed in memory is a waste of resources and an ugly hack).

  5. 826da7cf789a148d329130a527bf790e?d=mm

    tim-bluenose

    Nov 07, 2016 17:42

    Posting here since it correlates to this issue -

    We've encountered Full-stop crash bugs on iOS 10 / arm7 devices when attempting to unload streaming audio assets marked as "Load in Background". The sound doesn't play as described in the original issue, but we're also seeing lockups as well.

    Devices with arm64 work fine.
    Same devices pre iOS 10 work fine.
    Disabling "Load in Background" on all music clips causes it to work fine.

    After playing a music track marked to stream and load in background, the app freezes with a callstack looking roughly like:
    __semwait_signal
    nanosleep
    ::Sleep()
    ::FlushDisposedSounds()
    ::UnloadClip()
    ...

  6. Dda046f5309abdfdea1f7029d797a208?d=mm

    firtina

    Nov 02, 2016 10:38

    We have the fix for the issue (32-bit devices that use iOS 10 unable to load and play streaming audio). It is going through internal reviews at the moment.

    After the reviews have been completed it should be in all supported versions (including patches for 5.3 and 5.4).

  7. 209765a06ff6cdee4a7d186057f71efc?d=mm

    c_andrews

    Oct 28, 2016 09:26

    I have just started getting this issue with Unity 5.4.2f2 on Android when trying to stream an audio file from Persistent data or Streaming assets. I've got some background music playing but I don't seem to be able to play anything while that is playing:
    Error: Cannot create FMOD::Sound instance for resource ؚWT@��T�, (Operation could not be performed because specified sound/DSP connection is not ready. )
    UnityEngine.WWW:GetAudioClipInternal(Boolean, Boolean, Boolean, AudioType)
    UnityEngine.WWW:GetAudioClip(Boolean, Boolean, AudioType)
    UnityEngine.WWW:GetAudioClip(Boolean, Boolean)

    I get the same error on:
    - Samsung S6 running 6.0.1
    - Amazon Fire running Fire OS 5.3.1.0
    - Google Nexus 7 running 6.0.1

  8. 7892e1c956b2570a8ddef5b07f23b121?d=mm

    Avatar-Zero

    Oct 28, 2016 08:04

    This is not an iOS 10 specific issue. I have encountered it on an iOS 9.3.4 (13G35) iPhone 5s as well. Using Unity 5.4.1f1.

  9. 906507b2bc92f495e082fe8d18971c00?d=mm

    lightmont

    Oct 26, 2016 10:26

    You can see this bug on released games such as:

    - Best Fiends (Seriously)
    - Cookie Cats (Tactile Entertainment)
    - Toy Blast (Peak Games)
    - Slink Kong (Protostar)
    - Stampede Rodeo (Featherweight)
    - Crazy Kitchen (Zynga)

    The bug seems to only occurs on arm7 devices running iOS 10.0+.

    It's funny because you can now actually be sure which games are made with Unity. Just download it on a device on which the bug occurs and see if the BG music can be played.

    Two Dots, as far as I know, is made with Unity but the game does no have this issue.

  10. 8a316dcc176ad69be4efced4f7198df5?d=mm

    WillemKokke

    Oct 23, 2016 14:26

    Suffering from this on unity 5.4.2f1.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.