Search Issue Tracker




Found in



Issue ID




[HUB] HUB doesn't install the right Android SDK and NDK tools



To repro:
- get the latest HUB
- install the latest version fo 2019.3, with the Android module and SDK and NDK tools
- notice that, in the Preferences window, you'll get a warning that the tools are not installed and the recommendation to install them from the HUB (which we just did)

Reproduces on all 2019.3 (tested on 2019.3.0a9 and 2019.3.0a8)
Does not repro on 2019.2 or 2019.1
On Linux, Both NDK and SDK seem to have issues
On Windows and MAC OS I only noticed the warning for the NDK

Tested on HUB version 2.0.3

  1. Resolution Note:

    Fixed with Hub v2.0.4

Comments (29)

  1. andoo001

    Jan 09, 2021 16:23

    or should it be YWWGTIWWFLIS (Yeah we will get to it when we feel like it support?)

  2. andoo001

    Jan 09, 2021 16:22


  3. andoo001

    Jan 09, 2021 15:29

    HOW IS THIS RESOLVED ????? 2019.4LTS STILL DOESNT DETECT NDK, GO TO HUB, CAN'T INSTALL, CAN'T UNINSTALL AND REINSTALL, YOUR HUB IS CRAP. PLAIN AND SIMPLE. The only workaround ive seen other users successfully use is to change backend to mono. GOOGLE REQUIRES 64BIT BUILDS!!!! How is this on your TO DO LIST????? It needs to be fixed NOW.

  4. ahmedaniss

    Dec 09, 2020 03:16

  5. labpat

    Dec 02, 2020 08:22

    2019.4.14f and the issue is still present from the Hub! Spent many hours trying to resolve it.

  6. Algoros

    Aug 28, 2020 16:25

    still happening with UNity 2019.4 LTS ....

  7. marlon_1_23

    May 21, 2020 17:41


    I went to Android and downloaded the most current NDK, "ndk-r21b", and put that ndk into the

    C:/Program Files/Unity/Hub/Editor/2020.2.0a11/Editor/Data/PlaybackEngines/AndroidPlayer/NDK

    Now it works !

  8. mohOsama

    May 12, 2020 07:38

    Same problem in 2.3.1

  9. MatteoSunnyZ

    Apr 26, 2020 22:08

    (I am French sorry for the errors) I want to make a mobile game but Unity Remote 5 doesn't work, however I did install Android Build Support, Android tools SDK & NDK and Open JDK in the Unity Hub (the version is Unity 2019.3 .11.f1). But nothing works, I tried with a Huawei p20 and a Galaxi S8 +, if anyone knows how to help me please (I also put my phone in developer and put the PTP + download Android Studio, and download Google USB driver ( because I saw a video explaining that we had to do this) But nothing ... :/

  10. unity-lasvit1

    Apr 20, 2020 13:20

    I have same error on 2019.3.0f6. Below is the error:

    Detected outdated SDK Tools version 0.0 when the min version is 26.1.1
    UnityException: Failed to update Android SDK
    Error building Player: UnityException: Failed to update Android SDK.
    Build Steps:
    1. Build player
    [Warning] JDK was not installed with Unity at /Applications/Unity/PlaybackEngines/AndroidPlayer/OpenJDK, disabling "Installed with Unity" checkbox to look for alternative locations.
    [Warning] Android SDK was not installed with Unity at /Applications/Unity/PlaybackEngines/AndroidPlayer/SDK, disabling "Installed with Unity" checkbox to look for alternative locations.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.