Search Issue Tracker

Fixed in 5.4.0

Votes

102

Found in

5.2.0f3

Issue ID

726168

Regression

No

[Generic] Transition between animations is not smooth

Animation

-

How to reproduce:
1. Open attached project
2. Open scene "2"
3. Open Animator window and select "New Animator Controller" in Project tab
5. Select transition in animator window from "Beastslayer_idle_01" state to "Beastslayer_run" state
6. Play preview of the transition

Current result:
Approximately in the center of the transition the model quickly falls back. This problem is actual when Animation Type in fbx is set to "Generic".

Expected result:
Animation blends smoothly. The result is so when Animation Type in fbx is set to "Humanoid".

Comments (4)

  1. 07242c72fb299f835166278aacd2f4ee?d=mm

    v.nikolaev

    Dec 03, 2015 06:18

    Please vote on this bug this issue:
    https://issuetracker.unity3d.com/issues/transition-not-smooth-on-specific-asset
    Beacause it is the same bug.

  2. Ea996c9c3569d9babf78717ff42ee612?d=mm

    Llockham-Industries

    Nov 12, 2015 05:57

    Confirming this has been fixed in my use case as of patch 5.2.2f1, appreciate the hard work guys, ya'll are awesome.. :D

  3. Ea996c9c3569d9babf78717ff42ee612?d=mm

    Llockham-Industries

    Oct 19, 2015 04:05

    Am using 5.2.1f1, Experiencing the same issue, it appears random bones are rotating in the the opposite direction to the optimal. ie. if there is a difference of 15 degrees of rotation on the x axis it will instead rotate 345 degrees away from the target to reach the desired result.. but skips 180 degrees of the rotation over a single frame..

    Should also be noted this is occurring within Blend Trees as well as Transitions.. Of-course, only when using a generic Rig, issues stop when switching to Humanoid..

    If you need more example cases I'd be happy to upload my animations, they demonstrate the issue very clearly.. email - Daniel.Dickinson.8@gmail.com

    really need this fixed, good luck!

  4. 07242c72fb299f835166278aacd2f4ee?d=mm

    v.nikolaev

    Oct 06, 2015 06:17

    This bug also reproduces in 5.2.1p1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.