Search Issue Tracker

Fixed in 2017.3.0f3

Fixed in 2017.1, 2017.2

Votes

1

Found in

Issue ID

923377

Regression

Yes

Error "Must set an output directory through SetCompileScriptsOutputDirectory before compiling" after importing standard assets

Scripting

-

Reproduction steps:
1. Create new project.
2. Import Standard Assets from Asset Store.

Expected result: Assets will be imported "cleanly".
Actual result: Error "Exception: Must set an output directory through SetCompileScriptsOutputDirectory before compiling" appears.

Reproduced on: 2017.2.0a2, 2017.2.0a4, 2017.2.0b1.
Worked fine on: 2017.1.0f1, 2017.2.0a1.

Comments (8)

  1. D243a37db4fc14cd810b9903ef77c035?d=mm

    danvoidable

    Mar 03, 2019 22:44

    I had this error in 2018.2.17f1.
    I closed then reopened the unity project and the error went away.

  2. 7103ff9410224c06429c1ff717c600de?d=mm

    superfryme

    Sep 08, 2018 23:52

    so i imported my project and the errors showed up. turns out you can only have one editor folder so move your scripts into gaias editor folder to get it working

  3. 7103ff9410224c06429c1ff717c600de?d=mm

    superfryme

    Sep 08, 2018 22:50

    create a new project and import gaia and you dont get that error.

  4. 26cee5a0c17a97aac8e38e9da93c8ca3?d=mm

    MichiealO

    Aug 20, 2018 20:25

    So, looking at the source code for unity... I just have to ask... Why is this even in there?!?!?!

    public string GetCompileScriptsOutputDirectory()
    {
    if (string.IsNullOrEmpty(outputDirectory))
    throw new Exception("Must set an output directory through SetCompileScriptsOutputDirectory before compiling");
    return outputDirectory;
    }

    Unity Never allows the user to specify the directory... As it is automatically handled by Unity itself. SO, why the heck would it ever throw this error?! I mean, the logical thing to do (instead of throwing an useless error to confuse the user and make us spend weeks debugging the damned editor) is for when the error would occur, for them to simply reassign the value of "outputDirectory"....
    I'm just saying -- Seems pretty freaking idiotic to me.

  5. 26cee5a0c17a97aac8e38e9da93c8ca3?d=mm

    MichiealO

    Aug 20, 2018 13:41

    And.... I just got it in 2018.2.2f....

  6. 220f90186790e500f0c5881f91e1d579?d=mm

    azariahbeale336

    Jul 16, 2018 17:13

    hi

  7. 119e3277dd369a3e1411ca547949dbe6?d=mm

    visioomega

    Jul 02, 2018 02:47

    yep same here any one figger how to correct it?

  8. A89e34b97317e7093f017e310c4bad95?d=mm

    Cezarovsky

    Aug 29, 2017 03:02

    The same error on 2017.2.0b3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.