Search Issue Tracker

Active

Planned for 2020.1

Votes

1

Found in

2020.1.0b10

2020.1.4f1

2020.2.0a14

Issue ID

1276565

Regression

Yes

Editor crashes when upgrading/downgrading between 2020.1 and 2020.2

Packman

-

How to reproduce:
1. Create a new project named "20201" (2020.1.0b10 or above)
2. Close the Unity Editor
3. Copy the files from the attached "20202Test.zip" project (From the "20202Test" folder)
4. Paste the files to the "20201" folder
5. Open the "20201" project with 2020.2.0a14 and above

Expected result: The Editor loads without any errors
Actual result: Editor crashes with "The file 'Library/PackageManager/ProjectCache.bin' is corrupted! Remove it and launch unity again! [Position out of bounds!]" fatal error

Reproducible with: 2020.1.0b10 and 2020.1.6f1 (When upgrading to 2020.2.0a14 and above), 2020.2.0a14 and 2020.2.0b3 (When downgrading to 2020.1.0b10 and above)
Not reproducible with: 2018.4.27f1, 2019.4.10f1, 2020.1.0b9, 2020.2.0a13

Note:
- To reproduce the issue by downgrading simply open a new project with 2020.2.0a14 or any above and then downgrade to 2020.1.0b10 or above

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.