Search Issue Tracker

Fixed in 5.2.0



Found in


Issue ID




[Deferred] Trees created using Tree Creator generate white spots with deferred rendering path



Steps to reproduce:

1. Open the attached project
2. Open the 'GM Island' scene
3. Notice the white spots on the trees
4. Switch to any other rendering path
5. Notice the white spots are no longer visible

Comments (17)

  1. Yany

    Nov 19, 2022 18:42

    Wow, did you know guys this bug is still extremely apparent in 2022?

    Let me give some hints though. So I had a huge amount of white pixel sparks all around my terrain full of trees (created by the built-in Tree Creator tool). Mostly around those in the distance, but not only there. I realized them close to the camera as well thanks to the Bloom Post Process effect I use. Actually, this bloom effect made my scenario look like I'm at a concert where people in the audience took photos using flash constantly as my camera flew around the terrain. And it's not an exaggeration.

    Unity 2022.1.22f1
    Render Pipeline: Built in (no URP/HDRP used)
    Bloom Post Process: Intensity=56, Threshold=1.27, Soft Knee=0.4, Diffusion=10 (this is just for magnifying the issue to see if there's even a single white dot on the screen).

    What I did to SOLVE it:
    - I use a custom leaf texture from and I used photoshop to make it transparent, but my first mistake is here: I created transparent areas by selecting the needed area and pressing delete to actually remove those pixels from the picture. Don't do that, just leave the transparent area using a color that is around the average color of the whole leaf. Some green/brown stuff. And then define the transparency by using LAYER MASK. You can test the difference in Unity by playing with the Alpha cutoff parameter in the generated leaf material called "Optimized Leaf Material". If you set it to "0" you can see that the transparent texels are the green/brown thingy instead of pure white.
    - If you use Tree Creator, you might already know that there's a folder created for generated textures when you assign your Leaf material to the tree. We need to apply the following changes on the textures there to eliminate the white pixels ultimately:
    - Disable the "Generate MipMaps" or it's even better if left on, but then enable "Replicate border"
    - Change "Wrap Mode" to "Mirror Once"

    This should eliminate all white pixels. Remember to reapply these changes if this folder is regenerated by the Tree.

    Optional changes: I also changed the "Filter Mode" to "Trilinear" and the "Compression Level" to "High Quality"

    I hope this helped a few unlucky people running into this issue.

  2. FlorianBernard

    May 25, 2017 21:16

    This is not fixed in 5.6

  3. HardyM

    Aug 02, 2015 21:57

    I believe that's some kind of problem with z-buffer and shadows in deferred, and it extends to the legacy one. You can switch your path rendering to forward, and if it did not solve, toggle in the tree prefab the receive shadows option.
    For me worked using deferred, when I disabled the receive shadows in each one, but when I turn on Sun Shafts, Motion Blur or Depth of Field, it gives the same error.

  4. heskethgames

    Jun 29, 2015 21:11

    Still broken for me. Any solution yet? I am on 5.1.1f1

  5. Nieles

    Jun 02, 2015 20:25

    Still not fixed in 5.0.2!

  6. amarchal

    May 26, 2015 05:09

    Not fixed. I have tried all the betas up to 5.1.0f1 and I still see this issue. It says it was fixed in a future release, what release is being referred to? In my specific case the trees are being brought over from a unity 4.6 scene and they have gross white fringe coming from the optimizedLeafMaterial shadow component going all kinds of wrong under deferred shading.
    switching to to SM model 2 is not the real fix correct?

  7. Stargazer1974

    May 19, 2015 18:47

    For me, this is not fixed!

  8. Gregu

    May 05, 2015 13:17

    Bumping this.


  9. Remiel

    May 02, 2015 18:00

    "The White outlines on tree creator trees in forward rendering can be fixed by turning off Anti-Aliasing ."
    I have it turned off and the issue persists as shown in thread
    This is an issue with speed tree shaders.

    "I temporarily fixed it guys
    try to change your graphics emulation to shader 2 or 3"
    Turning the emulation to shader model 2 makes the issue disappear in editor, however, it still remains for shader model 3.

    This is a big issue as it makes me choose between using trees or using deferred. Naturally, it makes me unable to use deferred which is a huge problem in it's own right. Please fix this as soon as possible.

  10. Zaxs_Reaper

    May 01, 2015 15:01

    I temporarily fixed it guys
    try to change your graphics emulation to shader 2 or 3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.