Search Issue Tracker

Fixed in 5.3.3

Votes

0

Found in

5.3.0f1

Issue ID

747512

Regression

Yes

Custom font (Unicode) vertical alignment is wrong on "Text" component

UI

-

Text using custom fonts set to Unicode is aligned wrong on Text components in 5.3 (Too high on Y).

Repro Steps:
1) Open attached project and scene "Test"
2) Observe that the text in object "Text" should be center aligned horizontal and vertical but is too high on the vertical.

Regression from v5.2.2f1

Workaround: Use Dynamic characters

Comments (31)

  1. 89182cfdfd9a752dbb3e699166bce952?d=mm

    enchiridion

    Jan 09, 2017 15:17

    Bug still exists in 5.4.1f1 in 2017!!!! This is NOT fixed, can an admin please change the status of this bug and have it fixed asap, it is driving me insane.

  2. 2a4701205abeef0cbf5ab20499128f37?d=mm

    Leon700

    Sep 26, 2016 06:55

    Unity 5.3.4f1 (64-bit) and the bug is still alive... Kill it, please ;-;

  3. 10ea739e07a70922d70e384dee617655?d=mm

    HNiwayama

    Mar 30, 2016 09:31

    This is still not fixed in 5.3.4p1 for uGUI(Text).

    I have contacted to the Font developer which is using in my project. However font developer said "Our font data has no problem. Instead Unity has problem i think so."

  4. 2439c17fbadb6fe761afa3a92710fd2d?d=mm

    Linolium

    Mar 02, 2016 19:38

    This is still not fixed in 5.3.3f1 for TextMesh vertical alignment. View my post here for images of the issue: http://forum.unity3d.com/threads/5-3-text-component-vertical-placement-not-correct.372585/page-2

  5. 9e85103e8ed6a0e187583d7472943756?d=mm

    pfreese

    Feb 25, 2016 02:32

    Take a look at the metadata for the font. If there's a field for "use2xBehaviour 1" try changing that to a 0 and reimporting the font. Different fonts use their ascender field to represent different values, such as the top of the cell bounding box, the height of capital letters or something else. This can cause difference in vertical alignment between fonts. The use2xBehaviour controls how this value is determined from the font; if it is set the ascent value is determined from the cell height of the specified characters (which usually doesn't account for things such as diacritics, and will result in the text being placed higher than it should).

  6. 5c47876f94f10d1acc9929322a180f04?d=mm

    WILEz1975

    Feb 18, 2016 21:13

    Is present in the last Patch 5.3.2p3?

  7. 181ebfab9d0bcbca671c3dd7bf8b88dc?d=mm

    Ali Be

    Feb 10, 2016 15:17

    If you have a Custom Font with Custom Set try to rebuild texture:
    - remove one character from Set
    - press Apply
    - bring back that character
    - press again Apply.
    It helped in my case.

  8. D00ace363803b50295d2ecf9dda7169d?d=mm

    DimeX

    Feb 04, 2016 20:11

    It is still reproduced on Unity 5.3.2f1

  9. A1fa234fb244920e13151b18dec4ddbb?d=mm

    Usaruki

    Jan 29, 2016 14:55

    Actually this fix is on the patch release :v
    They released the 5.3.2f1 without the fix and the 5.3.2p1 with it.

    http://unity3d.com/unity/qa/patch-releases/5.3.2p1

  10. 3a1669616692cb6d08919764124eff00?d=mm

    radiantSil

    Jan 29, 2016 04:03

    Bug still exists in 5.3.2...

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.