Search Issue Tracker

Fixed in 2021.1

Fixed in 2019.4, 2020.1, 2020.2

Votes

1

Found in

2018.4

2019.4.0f1

2020.2

Issue ID

1255801

Regression

No

Cloth component behavior is altered when the frame rate changes

Cloth

-

To reproduce:
1. Open attached project ("case_1255801.zip")
2. Build and run
3. Observe the Cloth behavior in high frame rate
4. Now click the "Vsync" button and observe the Cloth

Expected result: Cloth behavior remains the same
Actual result: Cloth behavior changes, due to a frame rate drop

Reproducible in: 2018.4.24f1, 2019.4.1f1, 2020.1.0b13, 2020.2.0a15

Notes:
1. Also reproducible in Editor (see "Editor.mp4")
2. When FPS increase, the Cloth component range of movement seems to decrease

  1. Response avatar

    Resolution Note (fix version 2021.1):

    Fixed in: 2021.1.0a1

  2. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in: 2020.2.0b8

  3. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in: 2020.1.11f1

  4. Response avatar

    Resolution Note (fix version 2019.4):

    Fixed in: 2019.4.13f1

Comments (3)

  1. 8fd968c6ef551b25980104926c5f6322?d=mm

    Qriva

    Nov 13, 2020 03:14

    We just upgraded project from 2019.4.1f1 to 2019.4.14f1 and our character cloth is completely broken by jittering. For some reason "World Acceleration Scale" does not work correctly and cause the cloth to teleport like crazy. We are not able to setup it to work in the same (or at least similar) way as before.

  2. F7dd45640ced2bc8b5c72357650d18fd?d=mm

    dvoidis

    Oct 22, 2020 15:44

    I cant help to think that the force was suppose to scale with higher framerate to allow for higher precision physics. Now it just behaves like jelly no matter what settings or framerate i use. Hair pony-tails becomes inverted etc because the forces are too weak to hold it together. My only option is to either disable cloth entirely or restrict the particle movement so much they cant invert etc, but then its pretty much pointless to use cloth anyway.

  3. F7dd45640ced2bc8b5c72357650d18fd?d=mm

    dvoidis

    Oct 22, 2020 15:16

    So after this so called fix ( 2019.4.13f ) i am unable to setup cloth to behave the same it did in 2019.4.12. Basically no matter what settings i use ( stretch stiffness at 1, bend stiffness at 1 etc) cloth materials behave like jelly. I would expect a material with stiffness settings at 1 to behave pretty rigid, but it does not.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.