Search Issue Tracker

Status: Fixed in Unity 4.5.3

Votes

62

Found in

4.1.0a3

Issue ID

523691

Regression

Yes

Can't alt-tab back to DX11 Standalone

Window management

-

-

Priority: 1Fix for next beta/patch release build

-

Severity: 1Crash or major loss of functionality

Can't alt-tab back to DX11 Standalone

Repro:
1. Build and run
2. Start fullscreen
3. Alt Tab to switch to another app.
4. Try to switch back to the Unity standalone..
5. Goto 4.

Happens only when using DX11

Comments (17)

  1. 050a2deb5abdf9732c2ac704b20d70e4?d=mm

    fingerworks

    Aug 21, 2014 23:22

    It looks like this is fixed in 4.5.3f3. We had been using a shortcut with -popupwindow for about 10 months. Now it is not necc. Yay!

  2. 7f882f325dc7cc2c51464149f9a546af?d=mm

    RayWolf

    Apr 15, 2014 18:00

    My game build is crashing too.

    DX11 standalone build with win8.1 and unity 4.3.3 ...exakt same alt tab behaviour. this is a big BUG, that needs to be fixed asap imho.

  3. 804ffc3f18a331d8dfa710b06a307cd1?d=mm

    AndySum

    Apr 10, 2014 03:12

    Please look at this! Games can't be released with DX11 when there's a problem like this.

  4. 88d974d64bbc226bc808ae5185b1d4a5?d=mm

    clausmeister

    Apr 04, 2014 14:32

    having the same issue.
    really need a fix for this. win7 / win8, unity 4.3.2f1.

  5. 112370c99d538070c1109b6198d168c2?d=mm

    einWikinger

    Mar 25, 2014 18:36

    I think I found a "workaround" for this issue, at least I can get back into my fullscreen player this way:

    - Tab out of the player
    - Tab into the player (I then get a black screen for a short amount of time before it would switch back to the desktop)
    - Click into the black screen
    - Player comes back to foreground

    Anyone can confirm this works for their case? Tested on 4.3.4f1 Win8 32bit DX9 release standalone player

    Seems to be an issue with the main window not gaining the focus back.

  6. 112370c99d538070c1109b6198d168c2?d=mm

    einWikinger

    Mar 25, 2014 18:29

    We have this problem, too. Experienced on a wide range of machines. Every time when I ALT+TAB out of our fullscreen standalone build, the log has one more of these entries:

    HandleD3DDeviceLost
    HandleD3DDeviceLost: needs reset, doing it
    FullResetD3DDevice
    ResetD3DDevice
    dev->Reset
    D3Dwindow device not lost anymore
    HandleD3DDeviceLost
    HandleD3DDeviceLost: still lost
    Skipped rendering frame because GfxDevice is in invalid state (device lost)

    (Filename: Line: 1539)

  7. 1b58f2e39531fa321fa3056789dedd84?d=mm

    BuffaloPhil1

    Mar 21, 2014 03:09

    Same issue here, Unity 4.3.4.f1... Desperate for a work around if one exists. I've read people having success by turning off AA, but this has not solved it for me. Thanks

  8. 4494d68ec5eaefcd4ca1d7f45903ff48?d=mm

    scarpelius

    Mar 19, 2014 15:54

    Indeed, this is inadmissible.

  9. Feb19e9db93209ae7e98a1ca0f533a11?d=mm

    primus88

    Mar 19, 2014 14:24

    Unity, please fix this as it is critical.
    What is the point in have dx11 s feature when you cannot use it?
    It's impossible to switch to dx9 because I am using TCParticles, which require dx11 and which is approved by you guys...

  10. 361e84e4581eabecab663937f6afa8a8?d=mm

    PhoeniXTail26

    Mar 14, 2014 12:35

    Has there been any movement on this at all? I'm delivering a project in a week and am now being forced to choose between a DX9 build that doesn't crash when alt-tabbing and a better performing DX11 build!

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.