Search Issue Tracker

In Progress

Fix In Review for 2022.2.X, 2023.1.X, 2023.2.X

Under Consideration for 2020.3.X

Votes

16

Found in

2020.3.44f1

2022.2.5f1

2023.1.0b2

2023.2.0a7

Issue ID

UUM-26049

Regression

Yes

Cannot archive build for iOS using Xcode 13.3 when the project is built on a Windows machine

--

-

Reproduction steps:
1. Open the attached project “BuildRepro” on a Windows machine
2. Build the project for the iOS platform
3. Export the built Xcode project to a macOS machine
4. Open the built Xcode project
5. Archive the project Product → Archive

Expected result: The project is archived
Actual result: Error “Command PhaseScriptExecution failed with a nonzero exit code” is thrown in the Xcode console

Reproducible with: 2020.3.44f1, 2022.2.5f1, 2023.1.0b2
Not reproducible with: 2021.3.16f1

Reproducible on: macOS 13.1 (Intel)

Notes:
- The project built with 2023.1.0b2 gets stuck on the “Planning deferred tasks” process
- Did not look for regression because of the complicated steps needed to reproduce this issue

Comments (5)

  1. CameronDWills

    Feb 18, 2023 11:04

    It's probably worth mentioning that building in windows and then transferring over to a mac always worked without issues in Unity 2021, but ever since 2022 it won't work because of the way the pod install happens (not a mac guy so I'm not even sure what pods are), but it basically fails during the windows build process because you can't run pod commands on windows (you can see it failing in the Unity console log when the build is complete)

    You have to build on Windows, transfer to mac, and then right click on the folder containing your game files and open a new terminal window. You have to type the command: pod install (sometimes more than once)

    This creates a workspace file you'll need to open and build from that (don't open the normal xcode project file.. make sure it's the workspace). This worked fine in 2022.1 but now in 2022.2 you'll have to do that, plus the additional workaround from my previous comment

  2. CameronDWills

    Feb 18, 2023 10:27

    A workaround that works for me:

    In Xcode Project:
    GameAssembly -> BuildPhase -> RunScript
    Scroll all the way down to --data-folder= ....

    Replace with:
    --data-folder="$PROJECT_DIR/Data/Managed"

    I also had to add the following line:
    chmod -R +x *

  3. spacefrog

    Feb 10, 2023 18:39

    We are sitting and waiting to update our app to 2022.2 until this bug is finally fixed !
    The bug also manifests if you export from windows to iOS and trying to build that project on an MacOS build machine.
    If you do the export from the MacOS version of the unity editor, everything builds fine

  4. unity_B071AF8D72383D08A48C

    Feb 10, 2023 09:34

    This issue can be reproduced with editor 2023.1.0a21 on macOS 13.0.1 (Apple Silicon)

  5. Spellbook

    Feb 05, 2023 15:41

    We've not been able to release an update for our hundreds-of-thousands of iOS users in months. This is a critical *MUST FIX* problem.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.