Search Issue Tracker

Fixed in 5.3.7

Votes

52

Found in

5.3.5p4

Issue ID

807983

Regression

Yes

Projects without audio stop the external audio sources on Android

Android

-

Reproduction steps:
1) Build user's attached project
2) Import any audio to device (or use app like Spotify, Soundcloud etc.)
3) Turn on music and launch built game
4) Notice that music stops playing

Regression from 5.3.4p6

Comments (54)

  1. yotalien

    Oct 18, 2016 23:37

    5.4.1f1 not solved.
    5.2.5f1 worked.
    (tested devices: samsung galaxy S3/ASUS Nexsus7 2013).

  2. parisk

    Oct 12, 2016 06:48

    For everyone looking at this. External sound stops when Unity starts but then you can start it again. I tried spotify and it works. So it's not a big issue.

  3. davidk_43

    Oct 10, 2016 19:10

    This is nuts. Can't even up vote it anymore despite the regression. Anyone know if this is happening in 5.5? Might push on to the beta if so.

  4. querywilly

    Oct 07, 2016 21:44

    Where are the download 5.3.7 i not found.

    İm tested 5.3.6p7 not solved.
    im tested sound cloud and android music player but unity stop all sounds.

    Do you need additional settings?

  5. Morgan

    Oct 04, 2016 00:20

    Me three! On all iOS versions/devices, volume drops. Not sure if this is related to the Android issue, or separate.

  6. tim-bluenose

    Sep 28, 2016 22:08

    We've been seeing this ever since we upgraded to Unity 5.4.

    We were not using any audio, but iOS background audio (audiobooks, music players, etc) would cut volume in half. We have received many CS complaints about this in the last few weeks.

  7. jeein

    Sep 28, 2016 14:17

    This game is killing my business... It's so critical! All my users are leaving FIX PLEASE!

  8. parisk

    Sep 27, 2016 20:15

    This need to be solved. It used to work in older versions. Something broke along the way and Unity now stops external audio from other apps. Severity of this issue needs to be raised.

  9. Deathfate

    Sep 26, 2016 07:30

    I tried Disabling all unity audio and the music still stops... So what is the workaround for this to have a severity 3?

  10. macpatel

    Sep 24, 2016 15:35

    This bug is killing all the games. Please fix this ASAP and do notify us :(

    Tried latest 5.5.0B4, 5.4.1f1, 5.4.0f3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.