Search Issue Tracker

Fixed in Unity 4.5.5

Votes

81

Found in

4.5.0f6

Issue ID

617069

Regression

No

Application crashes on Android adreno based graphics drivers

Mobile Rendering

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 0Severity not yet defined

Application sometimes crashes under these circumstances:

- Unity Version: 4.5.0f6
- Target Platform: Android
- Hardware: Adreno graphics drivers
- Android Versions affected: 4.1.1, 4.1.2
- Models affected (roughly ordered by # of occurrences): Andromax-c, GT-I8262, SGH-T999, HUAWEI-Y300-0100, HUAWEI-Y300-0151, LT26i, C1905, C1904, SPH-M840, C5215
- Average memory usage has been 130mb and lower on these devices.

Comments (37)

  1. 418557f2ce23b3bacecefcd310f615f5?d=mm

    papirosnik

    Jan 31, 2017 12:31

    THIS IS NOT FIXED!
    Unity 5.5.1p1,
    Sony Xperia Arc S,
    empty 2d project crashes!

  2. 6d6e6c930b540e80b14425014086aad7?d=mm

    PlanetVaster

    Oct 25, 2016 23:33

    This is still not fixed, even in 5.3.6p7! Unity please fix this, it still crashes a few seconds after launch on a Samsung Galaxy S3!

  3. Ec67c2f307733be2f4a1e3e5639b4e51?d=mm

    sekari

    Jan 22, 2016 22:20

    Not fixed in Unity 4.6.8p4. We are seeing a lot of crashes from Adreno GPU based devices. Especially on Samsung SPH-L710, Samsung SGH-I747, Samsung SGH-I535. NEED URGENT HELP!

    We have couple of device logs from Play Store developer console:

    java.lang.Error: FATAL EXCEPTION [UnityMain]
    Unity version : 4.6.8p4
    Device model : samsung SCH-S968C
    Device fingerprint: samsung/d2tfnvzw/d2tfnvzw:4.1.2/JZO54K/S968CUDUANH2:user/release-keys

    Caused by: java.lang.Error: signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000008
    Build fingerprint: 'samsung/d2tfnvzw/d2tfnvzw:4.1.2/JZO54K/S968CUDUANH2:user/release-keys'
    Revision: '15'
    pid: 27790, tid: 27812, name: main >>> net.peakgames.amy <<<
    r0 00004000 r1 00000000 r2 58ad2b24 r3 c0042200
    r4 60e87798 r5 60f6f008 r6 60e54020 r7 00000090
    r8 59450128 r9 00000001 sl 0000001c fp 00000001
    ip 6ca44005 sp 5f522c48 lr 58ab02e7 pc 58aa5882 cpsr 532f4b34

    at libGLESv2_adreno200.leia_cmdbuffer_insertwaitforidle(leia_cmdbuffer_insertwaitforidle:17)
    at libGLESv2_adreno200.leia_cmdbuffer_context_preamble(leia_cmdbuffer_context_preamble:374)
    at libGLESv2_adreno200.rb_cmdbuffer_reset(rb_cmdbuffer_reset:522)
    at libGLESv2_adreno200.rb_surface_sync_for_resolve(rb_surface_sync_for_resolve:22)
    at libGLESv2_adreno200.leia_perform_resolve(leia_perform_resolve:448)
    at libGLESv2_adreno200.rb_resolve(rb_resolve:206)
    at libGLESv2_adreno200.rb_alloc_gfx_mem_pure(rb_alloc_gfx_mem_pure:198)
    at libGLESv2_adreno200.rb_mempool2_alloc_pure(rb_mempool2_alloc_pure:66)
    at libGLESv2_adreno200.rb_vbo_cache_vertex_attrib(rb_vbo_cache_vertex_attrib:284)
    at libGLESv2_adreno200.cache_vertex_array(cache_vertex_array:378)
    at libGLESv2_adreno200.cache_vertex_elements(cache_vertex_elements:590)
    at libGLESv2_adreno200.qgl2DrvAPI_glDrawElementsInstancedXXX(qgl2DrvAPI_glDrawElementsInstancedXXX:264)
    at libGLESv2_adreno200.qgl2DrvAPI_glDrawElements(qgl2DrvAPI_glDrawElements:6)
    at libGLESv2_adreno200.glDrawElements(glDrawElements:10)
    at libunity.003a7a68(Native Method)
    at libunity.0018c794(Native Method)
    at libunity.0018ca9c(Native Method)
    at libunity.001f4d84(Native Method)
    at libunity.000de824(Native Method)
    at libunity.000df328(Native Method)
    at libunity.000e4868(Native Method)
    at libunity.000ef274(Native Method)
    at libunity.000ef9b0(Native Method)
    at libunity.0010c2c4(Native Method)
    at libunity.002a02f0(Native Method)
    at libunity.002a1318(Native Method)
    at libunity.003d3870(Native Method)
    at libunity.003df554(Native Method)
    at libdvm.dvmPlatformInvoke(dvmPlatformInvoke:112)
    at libdvm.dvmCallJNIMethod(unsigned int const*, JValue*, Method const*, Thread*)(dvmCallJNIMethod:360)
    at libdvm.00028820(Native Method)
    at libdvm.dvmInterpret(Thread*, Method const*, JValue*)(dvmInterpret:180)

  4. B00c381aa4c6334acdfa5235e85386de?d=mm

    Nickyj

    Sep 03, 2015 10:38

    can confirm, this issue is still there( Samsung S3 with adreno only for me). Using Unity V4.6.8.
    Occuring at this line :
    Texture2D newText = new Texture2D((int)sprite.rect.width,(int)sprite.rect.height);

  5. 99fe84bfe60db8940280e16160d49df4?d=mm

    FedericoC

    Aug 14, 2015 22:58

    Same error here :/. Unity 5.0. Works with Samsung Galaxy S4 but no with Moto G and Galaxy S3. How can I implement the 1x1 fix? I have to add it on every controller?

  6. 1adaa74eac37f565708ad7de597eac0e?d=mm

    LeonardK

    Feb 24, 2015 08:54

  7. 7329b8bb59dd0f91479040a2b7fc5e7c?d=mm

    Liszt

    Jan 21, 2015 08:17

    Sorry my previous link is broken. I repaste it here ;) http://pastebin.com/Wk2M2jTK
    If this can help someone..

  8. 9f132832025021bb0a8e22525dc98945?d=mm

    DanRP

    Jan 21, 2015 02:39

    I'm experiencing this issue too on 4.6.1p4. So far I've had customers report this issue happening on Motorola Nexus 6 and a Samsung Nexus tablet which, I believe, both have an Adreno GPU. Since this issue is currently marked as "Fixed", I fear that it will be ignored by Unity. Is there a open bug reported for this issue that we vote up?

  9. 7329b8bb59dd0f91479040a2b7fc5e7c?d=mm

    Liszt

    Jan 14, 2015 15:13

    Some precision to my previous post. I paste you the stack trace :
    http://pastebin.com/3SkD0uhf

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.