Search Issue Tracker

Fixed in 2019.1

Fixed in 2018.3

Votes

0

Found in

2019.1.0a5

Issue ID

1090834

Regression

Yes

[Android] When USB debugging is not allowed, selecting or switching to Android platform causes an error

Mobile

-

How to reproduce:
1. Connect a device which doesn't recognise your machine (or in Developer Options select revoke USB debugging authorizations)
2. You will get a popup in device "Allow USB debugging", click Cancel or leave popup open
3. Create a new project
4. It uses Standalone Platform, Open Build Settings and select Android Platform
Result: error in the console
5. Switch to Android platform
Result: you get the same error again

CommandInvokationFailure: Unable to retrieve device properties. Please make sure the Android SDK is installed and is properly configured in the Editor. See the Console for more details.
/Users/ieva/Library/Android/sdk/platform-tools/adb -s "UBV0218412000859" shell getprop

stderr[
error: device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

Reproducible: 2018.1.9f2, 2018.2.9f1, 2018.3.0a4, 2018.3.0b6, 2019.1.0a1, 2019.1.0a5
Not reproducible: 2017.4.12f1

Tried and reproduce: Xiaomi Mi 5
Tried and didn't reproduce: iPhone XS Max device which didn't Trust the computer

Note: Project can be successfully built, so this issue is minor

Comments (1)

  1. 5a01bf351877ec78440339f7db6bad0e?d=mm

    azeemonline

    Sep 08, 2019 17:36

    Android Apps Download

    https://www.androidkaki.com/

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.