Search Issue Tracker

Fixed in 2020.2

Fix In Review for 2018.4, 2019.4

Fixed in 2020.1

Votes

0

Found in

2018.4

2018.4.26f1

2020.2

Issue ID

1271765

Regression

No

[Android] The Grabpass does not work when the Blit Type is set to Auto

Android

-

Reproduction steps:
1. Open the user attached project "TestGrabPass.zip"
2. Switch platform to Android
3. In the Project window under "Assets/Resources/Scenes" open "SampleScene.unity"
4. Make sure that in the Player Settings under Resolution and Presentation Blit Type is set to Auto
5. Build for Android

Expected result: The Grabpass works when the Blit type is set to auto (See notes)
Actual result: The Grabpass does not work when the Blit type is set to auto

Reproduces on: 2018.4.26f1, 2019.4.9f1, 2020.1.4f1, 2020.2.0a21

Reproduced with these devices:
OpenGLES 2 and OpenGLES 3:
N/A, Samsung Galaxy S9 (SM-G960F), Android 8.0.0, CPU: Exynos 9 Series 9810, GPU: Mali-G72
VLNQA00313, Huawei Y6 Ⅱ Compact (HUAWEI LYO-L01), Android 5.1, CPU: MediaTek MT6735, GPU: Mali-T720

Does not reproduce with these devices:
Vulkan:
N/A, Samsung Galaxy S9 (SM-G960F), Android 8.0.0, CPU: Exynos 9 Series 9810, GPU: Mali-G72

Notes:
-Issue does not reproduce if Blit Type is set to Always
-Enter Play Mode in the Editor to see the expected results

  1. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0b2, backported to 2018.4, 2019.4, 2020.1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.