Search Issue Tracker

Fixed in 2020.1.X

Fixed in 2017.4.X, 2018.4.X, 2019.2.X, 2019.3.X



Found in



Issue ID




[Android] Input.GetKey returns false when S-Pen is being used on Samsung device



To reproduce:
1. Open attached project
2. Build to Samsung device with S-Pen
3. Use the Pen on the mobile screen

Actual result: The pen does not work. Getting Mouse0 in Input.GetKey only at first draw call. Then you don't receive anything (Input.GetKey return false all the time you press S-Pen)
Expected result: The pen should work. When you press and hold S-Pen should get Mouse0 button pressed all the time while pressing S-Pen (Input.GetKey)

Reproduced with: 2017.4.33f1; 2018.4.9f1; 2020.1.0a4
Not reproduced with: 2017.4.32f1; 2018.4.8f1

Tested with:
VLNQA00219, Samsung Galaxy Note9 (SM-N960U), Android 8.1.0, CPU: Snapdragon 845 SDM845, GPU: Adreno (TM) 630
VLNQA00128, Samsung Galaxy Note8 (SM-N950F), Android 9, CPU: Exynos 9 Octa 8895, GPU: Mali-G71
VLNQA00015, Samsung Galaxy Note8 (SM-N950W), Android 8.0.0, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540
VLNQA00028, Samsung Galaxy Note4 (SM-N910F), Android 6.0.1, CPU: Snapdragon 805 APQ8084, GPU: Adreno (TM) 420

Note: Logcat attached.

Comments (15)

  1. OgoneTech

    Oct 30, 2019 10:52

    I have exactly the same error (no drag) with 2017.33. Thank for posting, because I can only do dashed in my drawing application. :(

  2. lastcode

    Oct 17, 2019 08:54

    Will the error be fixed in version 2019.2?

  3. lastcode

    Oct 14, 2019 11:38

    These methods are not called if you make a movement with the stylus
    public void OnEndDrag(PointerEventData eventData)
    public void OnBeginDrag(PointerEventData eventData)
    public void OnDrag(PointerEventData eventData)

  4. lastcode

    Oct 14, 2019 11:25

    The problem exists in versions 2019.2.8f1 and 2019.2.9f1

  5. sketchii

    Sep 26, 2019 10:19

    Thank you SO much for posting this, I was wondering what went wrong and thought it was due to updating the NET framework, tried so many other things. I rolled back Unity to 2018.4.8f1 and it works again! Yay!

    Just want to add that Samsung Galaxy Note5 (SM-N9200), Android 7.0, also doesn't work.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.