Search Issue Tracker

Fixed in 2019.1

Votes

0

Found in

2019.1.0a11

2019.2.0a7

Issue ID

1133867

Regression

Yes

[Android] Build&Run doesn't deploy apk on device when split APKs by target architecture is enabled

Mobile

-

How to reproduce:
1. Create a new project
2. Switch platform to Android
3. In Player Settings enable "Split APKs by target architecture"
4. Build&Run on connected device
5. Create a new folder for split APkKs

Actual result: apk are built, but it doesn't deploy on device
DeploymentOperationFailedException: Failed to retrieve version code from APK.

Expected result: compatible apk runs on device

Reproducible: 2019.2.0a7, 2019.2.0a4, 2019.1.0a15, 2019.1.0a11
Not reproducible: 2019.1.0a10

Comments (1)

  1. B5017fd52b8efde555b09c4519674ffc?d=mm

    Khafra

    Apr 17, 2019 03:27

    I've had this happen on Unity 2019.1.0f2. As soon as I removed the splitting of APK's it worked fine, took a little longer than normal but worked ok.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.