Search Issue Tracker

Fixed in 2021.2.X



Found in






Issue ID




An error is thrown after re-building a library of previous Editor version project when the Profiler of 2020.2 project is opened

Window management


How to reproduce:
1) Create and open a new project in 2020.1
2) Select the Default layout
3) Open the Profiler window
4) Close the project
5) Repeat steps 1-4 with 2020.2 (a reproducible version)
6) Delete the 2020.1 project's Library folder
7) Open the 2020.1 project
8) Observe the Console window

Expected result: no errors are thrown
Actual result: an error is thrown

Reproducible with: 2020.2.0a13, 2020.2.0b1
Not reproducible with: 2018.4.27f1, 2019.4.9f1, 2020.1.4f1, 2020.2.0a12

Thrown error:
Unknown managed type referenced: [UnityEditor.CoreModule] UnityEditorInternal.Profiling.CPUProfilerModule

Full title/description: An error is thrown after re-building a library of an older/previous Editor version project when a 2020.2 stream project is closed after opening up a Profiler window in it

  1. Resolution Note (fix version 2021.2):

    Fixed in: 2021.2.0a15

Comments (9)

  1. ComanderXXY

    Feb 08, 2022 14:19

    I managed to stop getting
    "Unknown managed type referenced: [UnityEditor.CoreModule] UnityEditorInternal.Profiling.CPUProfilerModule" on "2019.4.12f1"
    by loading a window Layout.

    Maybe Unity tried to open a window, that did not exist in this version.

  2. TorchYo

    Feb 07, 2022 12:20

    Same here with 2019.4.35f1 with fresh project with HDRP.

  3. unity_eAfrmPvqDFvy-Q

    Nov 18, 2021 14:20

    2019.4.12f1 The same happened to me. but when you create a new project. I created a new project in another folder. and the error did not go away. fast and easy. I delete the project with the error.
    (en espaƱol) me paso lo mismo. pero cuando cree un proyecto nuevo en otra carpeta, el error desaparecio, Asi que despues borre el proyecto con el error. y acomode el nuevo en la carpeta correspondiente.

  4. vra_unity

    Mar 17, 2021 18:49

    Same problem with 2019.4.21f
    Thanks EKPYROTICFROOD, helped

  5. Jack_Eatock

    Feb 20, 2021 12:07

    Thankyou EKPYROTICFROOD, your solution worked for me :)

  6. EkpyroticFrood

    Jan 14, 2021 22:04

    It appears to be caused by something in the layout that we carry into new projects from old ones.

    This will wipe that out, but it fixes the error for me:
    Close Unity.
    Find the file named CurrentLayout-default.dwlt (probably in the "Library" folder)
    Delete the file named CurrentLayout-default.dwlt
    Restart Unity.

  7. tlt

    Jan 03, 2021 07:01

    I have the same problem with 2019.4.11f1 with fresh empty project

  8. Profection

    Oct 15, 2020 19:12

    Same here with 2020.1.9f1 with fresh project with HDRP.

  9. p2s-fabio

    Oct 09, 2020 10:38

    It happens for me on a fresh project with URP on 2019.4.12f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.