Search Issue Tracker

Fixed in Unity 2017.3.0f3

Votes

0

Found in

5.6.0f3

Issue ID

898416

Regression

No

An error "Failed to re-package resources" appears during building the project when Target API Level is set to 4.4 and lower

Mobile

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 2No workaround

Reproduction steps:
1. Create a new project;
2. In Android Player Settings set Target API Level to Android 4.4 or lower;
3. Build the project on the device;

Actual result: an error "Failed to re-package resources" appears and the project does not build on the device.
Expected result: the project should be built on the device.

Reproduced with: 5.6.0b6, 5.6.0f1, 5.6.2f1, 2017.1.0b10, 2017.2.0a4

Cannot be tested on 5.5 and 5.4 versions because there is no Target API Level setting.

Resolution: Android documentation strongly recommends to always use the latest available target api level. When building the apk, Unity adds a couple of manifest attributes (which were added in API 17 and 21) and specifies a theme that was added in API 21. We've decided to remove api 16, 17, 18 and 19 from the target api level selection list.

Fixed in: 2017.3.0a6
Backported to: 5.6.3p4, 2017.1.1p2, 2017.2.0b9

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.