Search Issue Tracker

Fixed in 2018.2.X

Votes

9

Found in

2018.1.0b2

2018.1.0b13

Issue ID

1024139

Regression

Yes

[Allegorithmic] Substance Designer materials can't be used even if Substance plugin is installed

Substances

-

To reproduce:

1. Download attached project "BT_LWRP.zip" and open in Unity
2. Go to Assets > Materials
3. Try to edit "granite_grey_blue.sbsar" or "rock_surface_rough.sbsar"

Expected Result: After you select one of these Materials, you see that you can edit them in Inspector
Actual Result: After you select one of these Materials, you will get the error in Console:

"Assets/Materials/rock_surface_rough.sbsar: Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store"

Notes:
- This issue appears on Windows and OSX
- No matter if you have Substance plugin Unity or not, you will still get this error

Reproduced on Unity 2018.1.0b2, 2018.1.0f1 and 2018.2.0a8
Not reproduced on Unity 2017.4.1f1 and 2018.1.0b1
Regression on Unity 2018.1.0b2

Comments (8)

  1. A54a2dbf52432c60027fa7daab597bb6?d=mm

    Kamil1064

    Aug 18, 2020 13:11

    I was working on my big project, and now, few days before publish I get this fatal error.
    * All materials has gone (missing material in mesh renderers).
    * Every time I hit 'Play' button or go back to unity after making changes in any of my script unity 'is thinking', after that I get those errors.

  2. 9e12f00113bce60c4925363bf356b7c5?d=mm

    nigelmerlin_unity

    Oct 23, 2018 15:30

    i am a non programmer and the first time i use unity, i get 300 mother fucking errors, 999 warnings !!!, Do you think that we have the time to waste to fix all the unity errors, fuck you unity !

  3. C466279e29e9fd1e801026760cbb2350?d=mm

    RichTufty

    Sep 27, 2018 15:26

    I'm getting this in 2018.2.9f1

  4. D56a5c4cd35d99acf0c580c6dc972414?d=mm

    tmlab

    Sep 08, 2018 00:12

    Having this issue in 2018.2.7f1

  5. 3d2e79aeeefdf9ff02996d008dc58012?d=mm

    FargleBargle

    Aug 26, 2018 22:35

    Still present in a project I just updated from Unity 2018.1.6f1 to 2018.2.5f1 - I upgraded specifically to solve this bug, after seeing another bug report claiming it was fixed in the latest releases. Apparently not.

  6. 9a83c53813d53d3551f29a2b8f44e1dd?d=mm

    khross

    Jun 28, 2018 23:29

    Yep, the same happens here. In 2018.1.6f1

  7. E18569f62da82b0b80ae23740a47fb4b?d=mm

    nightcrawlerstudios

    Jun 03, 2018 23:23

    I have the same result as well. Have Substance plugin, repro'd on 2018.1.0f1 and 2018.2.0a8 .

  8. F854ad6566e9afc2a6b564c75ac52c4b?d=mm

    WorldEater

    May 09, 2018 09:31

    I get the same result whenever I attempt to build a project containing one of the materials.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.