Search Issue Tracker

Fixed in Unity 2018.2

Votes

45

Found in

5.6.0f3

Issue ID

899620

Regression

No

[Win] Stuttering sound of mp4 files, video lags

Video

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Secondary functionality broken

Steps to reproduce:
1. Open user attached project
2. Play the scene
3. Notice that the sound is stuttering, video lags

Expected result: The sound of an mp4 file should not stutter, video should not lag

Reproduced in: 2017.2.0a1, 2017.1.0b7, 5.6.1p2, 5.6.0b1
Reproduced using Windows 8.1

Comments (10)

  1. 0674041c71805652222f9b2ffa39c626?d=mm

    frankadoriv

    Sep 03, 2018 04:25

    Testing on 2018.2.6, It doesnt work, audio jumps on mp4 encoded and not encoded...

  2. Eae3b3e8ac8597914ba1a401fcf707a0?d=mm

    drwayyyne

    Aug 30, 2018 12:24

    Can anyone report that this has really been fixed for you? I'm experiencing a similar problem in 2018.2.5 and 2017.4.10 (less severe in the LTS release but still existent).

  3. Cab93012bf7550234ec2d36f70fa232e?d=mm

    syazani2902

    May 02, 2018 23:36

    I found a slight improvement by importing a wmv and asking Unity to transcode it instead. Such funnyness, given the fact that the player was built for mp4

  4. F189e40ad0c4c1c8b525fb0ba02cdb5e?d=mm

    Jayme65

    Feb 20, 2018 09:11

    Come on! Bug reported nearly 1 year ago!!

  5. E0d52a801a7475f25994e7cf0bc8a19f?d=mm

    derdimi

    Dec 05, 2017 18:27

    On HoloLens I fixed this issue by separating the AudioSource and VideoPlayer components so they are not on the same GameObjects.

  6. 863e9056c1f94fbb3acd52c4c03eeb6b?d=mm

    Hades714

    Sep 24, 2017 10:49

    I'm still patiently waiting for a fix, or at least a reply from the devs. I hope they get around this issue and find a solution to this type of bug. I have seen in the changelogs (release notes) that they have fixed a lot of VideoPlayer related things... but no mention of this problem yet.

  7. F189e40ad0c4c1c8b525fb0ba02cdb5e?d=mm

    Jayme65

    Sep 21, 2017 20:12

    Bug was reported since march 2017 (7 months ago!)!
    Will it be fixed soon!?

  8. 213ba226b8a3af84f712872a9194e18e?d=mm

    JDMulti

    Aug 12, 2017 12:38

    Found the issue in all version from 2017.1.0f3 and up. Brand new feature (VideoPlayer) is completely unusable for both normal and VR use. Hopefully someone is going to look into this VideoPlayer more seriously. Right now EasyMovieTexture is the best cheap solution that works.

  9. 8f6aa0cc0f1d81a44e0b88916157e615?d=mm

    GeekyMonkey

    Jul 01, 2017 00:09

    Any workarounds? Would some specific video encoding lessen the problem?

  10. D71443b5a3c041684a75390a4b559fde?d=mm

    Arvin6

    Jun 28, 2017 08:37

    I get this issue on my iPhone 6S as well. Any workarounds will also be appreciated for now.

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.