Search Issue Tracker

Fixed in 5.4.0

Votes

16

Found in

5.4.0b12

Issue ID

785035

Regression

No

[VR]Terrain Trees appear black in build

VR

-

1) Setup EITHER headset
2) Build and Deploy to Windows Standalone
3) Run the Build
4) Put on the headset and observe that some of the funky trees appear totally black

Repros on Oculus CV1 and Vive here:

Version 5.4.0b12 (f0bd833f497f)
Wed, 23 Mar 2016 11:05:15 GMT
Branch: 5.4/staging

and

Version 5.3.4p1-ovr (c0107ac1a11a)
Thu, 24 Mar 2016 13:48:45 GMT
Branch: 5.3/partner/oculus/release-build

Comments (11)

  1. 97742d966b1c53a149130f0b4f5dd538?d=mm

    OURY

    Aug 02, 2016 11:45

    Also occurs with unity web player since the latest update :(

  2. 54094ad6ef82ba6697fc6dc9173c8e90?d=mm

    plyrek

    Jun 21, 2016 17:13

    I just wanted to let everyone know that I was able to fix the black tree issue in a kind of unintentional way. On a whim I moved my terrain asset to the top of the hierarchy and ta da the trees rendered properly every time. It also appears that a fix has been implemented in 5.422b as well but if anyone is still having problems try this trick.

  3. 54094ad6ef82ba6697fc6dc9173c8e90?d=mm

    plyrek

    Jun 16, 2016 18:16

    If anyone who has left a comment on this issue has found a solution please let us know. This issue is not fixed for all of us.

  4. 55397ef7316ac3b8981ce0cc774accac?d=mm

    emoc11

    Jun 12, 2016 11:02

    Still not good on Unity 5.4.0b21 !!!!!
    PLS FIX IT i need it to work now :'( ....

    I think it's on DK2 only ! Please help !

    im on runtime 1.3, my dk2 works fine with it, in unity i can play it without any error / black tree...
    On standalone for windows, the first time is good and all other the tress are black without any more error in developer console.. !

  5. 54094ad6ef82ba6697fc6dc9173c8e90?d=mm

    plyrek

    Jun 10, 2016 02:00

    The bug says it was fixed but it is still happening to me with 5.4.b20.

  6. 236e5883a2b3fb6a2cb4b2b62475a12d?d=mm

    OzzyBozzy

    May 31, 2016 17:13

    Occur in some builds and not in the others wuth no settings change. And yes, occurs with distant trees as well.

  7. 4b01088b310c9498faa8527cab94584f?d=mm

    laynardo

    May 26, 2016 21:44

    This is a huge issue right now for me and my clients. And these clients are people like IBM and Chevy. They are asking me to switch to Unreal now, which I don't want to do.

  8. B2b7ddde95eac23f69e6e1b5fb87ea20?d=mm

    SDM51

    May 07, 2016 00:33

    Along with the black trees, distant trees disappear in build/do not billboard correctly. Don't know if others have long view distances in builds, hence mention it here. My details are in one of the above mentioned threads.

  9. 3cdc4ae201e4bb5d3ccac9cd1438326c?d=mm

    pjenness

    May 01, 2016 10:33

    Getting this also. Please fix if this is a Unity bug.

    Thanks!!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.