Search Issue Tracker

Duplicate

Votes

107

Found in

5.3.0b4

Issue ID

740617

Regression

Yes

Using Content Size Fitter or Vertical Layout Group causes error

UI

-

When using the Content Size Fitter OR the Vertical Layout Group components on the Content of a Scroll View, and playing the scene an error pops up:

Trying to add (Layout Rebuilder for) Content (UnityEngine.RectTransform) for layout rebuild while we are already inside a layout rebuild loop. This is not supported.
UnityEngine.Canvas:SendWillRenderCanvases()

2. How we can reproduce it using the example you attached:
See the attached video.

1. Create a Scroll View add Text GO to its Content
2. Add the Content Size Fitter component on the Content
3. Press play
4. Notice the error. Exit play mode
5. change the attributes of the content fitter: Fit - minimum size
6. play again
7. Notice the content size is now fixed
8. set the attributes of the content fitter: Fit - Unconstrained
9. play again,
10. the content size is still fixed

regression from 5.2.1f1

  1. Response avatar

    This is a duplicate of issue #739376

    Error while resizing console window

Comments (61)

  1. 64997828c7bb6a64e0f8a050a5963125?d=mm

    iamarugin

    Jan 09, 2016 12:12

    Reproduced. Please, stop release showstoppers. And try to use Unity to making games.

  2. 732589fbde398df7e38a258e3803f23c?d=mm

    PhilBoo

    Jan 09, 2016 12:10

    And what Vapid Linus said. This bug still exists and is not a duplicate.

  3. 732589fbde398df7e38a258e3803f23c?d=mm

    PhilBoo

    Jan 09, 2016 12:08

    Still there and terrible annoying. Please fix!

  4. D78f33538a927d68bdc6b85d38db6a3e?d=mm

    Vapid-Linus

    Jan 08, 2016 22:11

    This is not a duplicate and is still happening in 5.3.1f1

  5. D78f33538a927d68bdc6b85d38db6a3e?d=mm

    Vapid-Linus

    Jan 08, 2016 22:07

    Still happening in 5.3.1f1

  6. 7e82b490cab62182c5c09629299a2f91?d=mm

    Beloudest

    Jan 07, 2016 18:37

    5.3 sucks, getting this too plus another 600 red errors. Ready to kill myself.

  7. Ccbfc0178227b3b354a6f30b16f647ec?d=mm

    DeeCeptor

    Jan 07, 2016 18:33

    Still not fixed as of Jan 7th, 2016. Would be wonderful if it were fixed.

  8. 477f3863d7c0947f1a119a81c7691c14?d=mm

    _methotec_

    Jan 06, 2016 07:53

    We have the same issue - worked fine in 5.2.x stopped working in 5.3.0, not fixed in 5.3.1
    And as mmoczkowski wrote -
    "... this is not a duplicate ..."
    This happens always if you resize an ui element by code with some layout controls in the child hierarchy. 100% reproducible

  9. 2e9620ca820c6afce61dac5715355672?d=mm

    TimGS

    Jan 01, 2016 21:53

    2 MMOCZKOWSKIDEC 29, 2015 15:51

    Karl said in forum that he put backport request for this. So it's probably going to be fixed in 5.3.1p2 or p3

  10. 68ee503c955fe562536d23bd50babc10?d=mm

    callen

    Dec 30, 2015 17:47

    Not fixed, terribly annoying, and the worst part is Unity tells you to do it in their videos: https://unity3d.com/learn/tutorials/modules/beginner/live-training-archive/creating-scroll-lists-at-run-time

    Just more proof that unity needs to spend more time actually using their tool, to actually make games, like almost every other engine developer

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.