Search Issue Tracker

Postponed means that the issue was either a feature request or something that requires major refactoring on our side. Since that makes the issue not actionable in the close future we choose to close it as Postponed and add it on our internal roadmaps and technical debt pages instead.




Found in [Package]


Issue ID




[URP] Scene view is not rendered, errors are thrown

Package: Scriptable Render Pipeline Universal


To reproduce:
1. Open Universal Rendering Examples project (;
2. Upgrade project to master branch of SRP;
3. Open "SplitScreenDemo" scene;
4. Open scene view.

Expected result: scene view is rendered, no errors are thrown.
Actual result: scene view is not rendered, errors are thrown:

Can't add 'UniversalAdditionalCameraData' to SceneCamera because a 'UniversalAdditionalCameraData' is already added to the game object!
UnityEngine.GameObject:AddComponent (System.Type)

ArgumentNullException: Value cannot be null.
Parameter name: dest

Reproduced with 2020.2.0a17 and 2020.2.0a19
Reproduced with URP 8.1, 8.2, 10.0

Reproduced on mac.

  1. Resolution Note:

    The component workflow that is in the making will make this bug go away.

Comments (6)

  1. Katerlad

    Oct 20, 2022 21:32

    Happend to me as well, random Universal Additional Camera Data script was added to the camera, deleted and issue was fixed.

  2. unity_yMt1zKD_LFJveg

    Sep 07, 2022 13:36

    Mine Camera object got second Universal Additional Camera Data script out of nowhere. I just deleted it and project works as expected again.

  3. MorphVGX

    Mar 28, 2022 21:15

    Yeap, creating the object again without the Universal Additional Camera Data duplicate, solved my issue.

  4. SM0K3R

    Nov 14, 2021 20:18

    SERGI1397 thanks
    my problem was fixed when I remembered after upgrading to higher unity version
    I had an error on my camera prefab, then fixed the camera prefab but I forgot to fix the prefab was already in my scene
    after overriding the prefab everything was fix

  5. HouseTrapDev

    May 30, 2021 20:29

    SERGI1397's solution worked for me. No idea why it happened to start with though, it was pretty spontaneous.

  6. sergi1397

    Sep 15, 2020 23:20

    At the moment the same thing is happening to me and I have come in search of answers, I do not know very well why, but in my camera the script "Universal Additional Camera Data" has been duplicated and it is what causes the errors, the only SOLUTION I have found for do not throw the work is to create a new camera copy all the variables and / or children of the prefab, I hope it helps you

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.